psychopy.org | Reference | Downloads | Github

2021.2.3 Bug: Resources not loading

URL of experiment: BalloonAnalogRiskTask_v7 [PsychoPy]

Description of the problem: Resources are not loading at start-up despite being uploaded in builder. This results in an unknown resources image error. This does not happen in an earlier version (V2021.1.4) as seen here: BART_v3_6.22.21_jg [PsychoPy].

1 Like

Hi, I came here to also report this issue. When I go to pilot the experiment, there is no progress bar shown but I can click Ok. When I do that I get an unknown resource error. Here is the URL of my experiment: Daniela Palombo / CBA_TD_E4 · GitLab

1 Like

@Becca or @thomas_pronk any idea?

Are the resources listed in the experiment settings > online > additional resources box?

Becca

They are. That is why this is so weird!

and checking - there isn’t any chance you loaded on a mac then changed over to a windows and pushed again? (or vice versa) if so, please can you remove the resources from the box and reload

There probably has been some MAC/PC pushing/syncing. Can that really cause a problem?

Why would that cause issues for 2021.2.3 but not 2021.1.2?

Not usually (and not for a while for me), but I encountered something specifically before (although in version 2021.1.3) where I made an experiment in windows, that used back slashes when setting the paths to resources, then I sent the experiment to a mac user and when they synced it the resources couldn’t be found, so they just reloaded the resources on their builder (which used front slashes) and that fixed the issue. Please could you test if that fixes your problem? Then we will know if it is that bug rearing it’s head again.

Thanks!

I finally got it working by starting over from a clean work folder: BalloonAnalogRiskTask_v8 [PsychoPy] and here is the Gitlab page: Jason Geller / New_BART_Jenn · GitLab. However, resources are still not loading at the start. Is that something new? I do not see that a resources folder was made either when adding new resources.

A resources folder shouldn’t be made any more no (if you are refering to html). I see what you mean about not seeing the resources load. I wonder if that is either because of the different background colour for the task or because there are so few resources to load - I’ll investigate.

Pleased you got it working though,
Becca

Hi,
I had the same issue after upgrading (see previous post on this forum) with allas no elegant solution. The thing that ‘solved’ it for me was to clear all hidden files and reprogram the entire experiment in the latest Psychopy version 2021.2.3. Not really a solution but may be more time saving then trying to fix this weird bug?

Hello,
I also seem to have this problem online with an experiment that worked previously and worked locally on psychopy. The resources bar seems to partly load then stop, but I can press ok to continue with the experiment. Then I get a message than an image is undefined. (No switching between Mac and Windows here.)
Thankful for any help!

OK thank-you all for reporting this. Please can I also check if this error occurs when you use experiment settings > use version > select the version the task was made in and resync

Thanks
Becca

Hi, reverting to the older version (2021.2.0) solved the resource loading issue - the bar goes to the end as normal. But I still got an error message:
when setting the image of ImageStim: P5
TypeError: r is undefined
I don’t know what r is, and it is possible this is a different issue to do with my code.
I set one of the images to ‘undefined’ intentionally, when I don’t want an image presented in that component. This used to work fine but might be a problem now? Any other ideas to present an ‘empty’ image component?
Thanks! Donna

Aha ok - to check if that is the issue in your case I would suggest setting the position of the image to be wildly offscreen in those cases (but use an actual placeholder image rather than undefined - I suspect using reserved JS terms might cause issue). If you still encounter issues with that specifically - please can you start a new thread? as it sounds like it could also be a separate thing going on.

Thanks,
Becca

1 Like

Good evening everyone,

I am looking into the matter. I made a few changes to the downloading of resources for the latest version but am surprised that it would have affected you in this manner.
@jgeller112 Would you mind giving new_bart_jenn another go? I was not able to reproduce your issue on my end but I made a change all the same, which might solve it on yours.
In the mean time, I’ll keep digging.

Alain

The resources are now being downloaded! Weird.

I am very glad to hear it!
All the same, there might be a particular network configuration that brings out the issue, so I shall keep digging.

Alain

Hi,

I’ve just created a post about this as I’m having the same problem: https://discourse.psychopy.org/t/unknown-resource-error-when-importing-conditions-after-updating-psychopy/24848

I’ve also tried what Becca suggested (to run using an older version) and it works again. Do you have any further suggestions for what I can try to get the resources to load in the latest version?

Thanks a lot,

Tegan