Problem with loading resource files on Pavlovia

URL of experiment:

Description of the problem:
This experiment was originally created in the 2020 version of PsychoPy. I had to switch to the most recent version of the program, and sync the updated version of this experiement with this version of PsychoPy. Now, resource files don’t load in the beginning of the experiment, and I keep receiving errors about missing resource files:

All resource files are copied to the html/resources folder, and checked for typos (although there might be some accidentally).

What can be the problem and how could it be solved? Unfortunately, switching back to the 2020 version is not really an alternative. :frowning:


Here are two links you should follow:

Hi @wakecarter, thank you for your response. I’ve followed the instructions on the second link step by step. Now, the program fails to compile the experiment to .js files:

If I copy the older .js files in the folder, it doesn’t update them, so the same loading error persists when run online. I’ve also tried to put empty .js files in the root folder with the proper names, but the program doesn’t update them either, plus the syncing fails.

Do you have any ideas what can be done?

Updated repository: MTA-BME Lendület Nyelvelsajátítás Kutatócsoport / PILOT_SEGM_AL_complex_r2v2_1key · GitLab

Try deleting all of the files that were created by PsychoPy apart from the psyexp file and start again. I don’t touch the js files. If they aren’t being created then look for an error message.

Unfortunately, deleting all files created by PsychoPy didn’t solve the issue. Finally, I restored the 2020.1.3 version and now it works fine.