psychopy.org | Reference | Downloads | Github

Unknown Resource Error in modified task

URL of experiment:
Code: Sign in · GitLab
Task: Pavlovia

Description of the problem:
We’ve made changes to a task that worked last year. When attempting to pilot the modified experiment, we see the opening gui and then the following error:

We attempted to create a new repo for the same experiment as described in this post, but the error has persisted. We’d like to avoid running it in an earlier version of PsychoJS (as suggested here) if we can so we can take advantage of new features. Anything else we should try?

Did you remove html from Experiment Settings / Online when you created the new repository or are you still running from the html folder?

We hadn’t when we made the new repo, but we made the change last night and the error has not cleared. Do you think we need to copy the repo again, then delete the .git/.gitignore/html folder and change that setting all at once?

More info that might be relevant: the resources are specified in code based on an input GUI parameter (for example, if input conditionType==2, use conditions file instructions_condition2.xlsx).

You need to copy to a new local folder and remove html from Experiment Settings and then sync that to create a new repository.

My colleague has done this and encountered the same error. Here’s the new experiment:
task: Pavlovia
code: Sign in · GitLab

We’ve now figured out that if the name of the conditions file is hard-coded into the loop settings, the resource loads fine (pic 1 below). But if it’s saved as a variable and that variable is used in the loop settings, it does not (pic 2 below). Adding the conditions file to the “Additional Resources” field of experiment settings-> online did not solve this issue.


I note that in your psyexp file you still have
even though you don’t have an html folder in your repository.

I’m not sure what could have caused that if you created the new repository by using the sync button.