psychopy.org | Reference | Downloads | Github

Windows 10 psychopy builder doesn't start


#1

If this template helps then use it. If not then just delete and start from scratch.

OS Windows 10 home 1803
PsychoPy version PsychoPy3 (3.0.0b1):
Standard Standalone? (y/n) yes
What are you trying to achieve?:
Start builder
What did you try to make it work?:
Doesn’t start
What specifically went wrong when you tried that?:
No message error is provided, psychopy just doesn’t start, whether I run it as administrator or not.


#2

me too, the builder does not start when i click it


#3

Tried running it from command prompt. Nothing happens.
I tried to run the file pythonw.exe, because this is the one to which the shortcut in the start menu points to.


#4

I tried to run pythonw.exe,but still did not work…
Did anyone run it successfully?


#5

Try installing git (https://git-scm.com/)

I think sets up necessary components for the online repository and fixed a similar issue during alpha testing.


#6

Did installing git work?

If not, running it from the command prompt should give a traceback error which can help to identify the issue! That’s what I did when mine couldn’t launch (the splash screen came up, then disappeared, and the programme didn’t launch), and it helped me resolve the issue.


#7

We’ve made quite a few fixes in the last few weeks. Try the new 3.0.0b6 but the advice from @mickeymich08 is also good. Running from the commandline helps us work out what’s wrong:


#8

I’m having a similar problem. I just installed PsychoPy 3.0.0b12 on my standalone laptop and found that while the Builder come up, when I try to load an experiment, nothing happens. If I run psychpyApp from python.exe, everything seems to be fine. I do get a warning about the ‘OSF Project ID’ is not known.

(perceptionlab) C:\Users\data.collection>python -m psychopy.app.psychopyApp
pygame 1.9.4
Hello from the pygame community. https://www.pygame.org/contribute.html
7.4628 WARNING Parameter ‘OSF Project ID’ is not known to this version of PsychoPy but has come from your experiment file (saved by a future version of PsychoPy?). This experiment may not run correctly in the current version.
gitpython and a git installation required for getProject()

Maybe the problem is because pythonw.exe has no place to output error messages?

Actually, this may be a conda install issue. I didn’t have the Coder view up before, but when I brought up the Coder view and went to open the psyexp file, I got a message about gitpython and a git installation are required for getProject(). gitpython was installed in my conda environment, but if I try and import it into python, I get a ModuleNotFoundError.


#9

I did a conda uninstall gitpython,
then a pip install gitpython, but that didn’t help.
I may be submitting an issue on gitbhub soon. For now, though “Open with python.exe” will, work.


#10

Looks like this works with pythonw.exe as long as the Coder view is up.