**Unspecified JavaScript error**

URL of experiment: Pavlovia

Description of the problem:
When running my experiment on google chrome I get the following error:
Unspecified JavaScript error
the developer console shows the following:

Google is not throwing up anything.



Tricky! If you get uninformative error messages, it can be useful to remove parts of your experiment until it does work; that gives you an idea of what part causes the error.

I had the same error. It was probably incompatibility between v2020.1 and v2020.2. Did you create the experiment in 2020.1, or put it online in 2020.1? Pavovia indicates this at ‘Platform Version’.
Try Edit Experiment Settings -> Use PsychoPy Version -> 2020.1

1 Like

Thank you! this worked. In the newest psychopy standalone version, I went to experiment settings and selected what version of psychopy it should to run on.

So I got the same error again after having to fix a problem with a conditional loop exit. This time after creating this portion of the experiment from scratch on the newest version of standalone.

what I have tried:
removing all code components and just running the experiment in its simplest forms
forcing to run various different versions of psychopy (inc. 2020.1 and 2020.2)

The pavlovia link: