Unknown survey error

Hello all,

I’m new to using Pavlovia Survey and connected it to another experiment of mine on Pavlovia. But after publishing it, I noticed a problem. About 20-30 credits were reserved, and after 4-5 hours, they turned into aborted sessions. Some participants sent me feedback with an error message (I attached the picture). The strange thing is, I didn’t get any errors when I tried it on three different computers, and around 10 people finished the experiment without any problems.

Since I’m not experiencing any errors myself, I’m a bit stuck and don’t know what to do. Can someone help me figure this out?

Thank you in advance,

This is for an embedded survey, isn’t it? Has the survey been set to running? Do you have edit access to it? I’m wondering whether it is some kind of permission error.


Both the experiment and the survey are in running mode, and there is enough credit in the experiment. I don’t know how to edit access, I only create the questions and link the experiment. I put the pavlovia experiment link in the “Completition Url” in the Survey. It is working for me and three other computers that I have tried.

Thank you,

When did this happen? Have you tested on both Mac/Safari and PC/Chrome + Edge?

Please could you give the link to the experiment?

We tried with MAC/Windows Opera, Chrome, and Firefox and didn’t encounter any errors. Some participants tried with Chrome and Safari but they received an error message.

Here is the link, …
We have set it to not save the data of incomplete sessions, so feel free to try.

Thank you again,

That’s the link to the survey. I assume the issue happens when you try to launch the experiment that embeds it. If so, what it the link to that experiment?

Yes, that was the link of the survey but it linked to the experiment Here is the link of the experiment.

Participants indicated that they were encountering this error prior to the survey.

I’m not getting the error myself (assuming it happens before the first instructions page loads) on Chrome or Edge on my PC. Is it possible that the issues occurred during the server move just over a week ago?

I’ve flagged this post for Alain to look at but he’s on leave this week.