Survey embedded in experiment: Automatically proceed to next routine

I´ve created an experiment that starts with an embedded Pavlvia survey and after the last question of the survey, it should automatically continue with the next routine in the experiment flow.

This worked perfectly fine - until today. At the moment, the survey simply ends with the “survey complete” page (or a blank screen, if I un-tick the respective box). I didn´t change anything in the experiment that seems to be related to that issue (just typos or font sizes in some textboxes later in the experiment), at least not on purpose…

Does anyone have a clue how this could be solved? The survey page on Pavlovia seems to look slightly different than before - has there been an update that could have caused this problem?

I tried to embed the survey both via ID and json file - neither works.

Thanks so much in advance!


There has been an update. I’ll try to replicate this issue now.

Best wishes,


I’m not seeing any issues with my embedded surveys (in 2023.2.3 or 2024.1.0)

Have you added any code to the survey completion, e.g. here:

or here

Thanks for the prompt reply! I´ve neither added code here:


nor here:


Would I need to add any code? If I understand that correctly, the experiment should automatically proceed to the next routine after the survey (at least that´s what worked before).

At the moment, the experiment gets stuck on the survey completion page and doesn´t reach the welcome routine.

(using 2023.2.3)

Please could you post add code to Begin Routine of checkSurveyVariables? Something like

print('Checking Survey Variables')

and post a preview link (or live link) to your experiment so I can see for myself?

I did so but “checking survey variables” doesn´t appear in the console - the console ends as follows:

The survey seems to get stuck at the survey completion page and doesn´t reach the checkSurveyVariables or welcome routine (both contain text - the checkSurveyVariables routine shows text depending on the survey responses).
At the moment the experiment gets stuck showing a blank screen but when I want the survey completion page to appear, it ends with the text of the survey completion page and doesn´t get any further. So I really think it´s about the survey and not the first routine of the experiment.

Here´s the link to the experiment: Pavlovia

I couldn’t see anything odd, except that it seemed to submit without waiting for me to click complete when I said that I didn’t speak German.

What happens if you embed a different survey that just has one simple question and no logic?

Did so - same result, I get stuck here:

Ok – next try embedding your original survey into a new experiment (initially just the survey routine followed by a routine with a text component and then try pasting in your checkSurveyVariables and welcome routines…

I embedded a completely new survey into a completely new experiment and I´m still seeing the same result - no proceeding to the next routine.

Please could you share the new repository (add me as a developer) and survey with me (Wake) so I can investigate further?

Here are the results of my investigation.

If you use PsychoPy 2023.2.3 then you can embed surveys created prior to the latest update (approx 27 March 2024) but later surveys fail to return to the experiment

If you use PsychoPy 2024.1.0 (which contains improvements to the survey component) then new surveys do return to the experiment

I would therefore recommend upgrading to 2024.1.0 now if you are using embedded surveys. However, I will also raise the issue with the team in case there is a simple tweak that can be made to the new surveys to make them backwards compatible.


Great, then I´ll go with the upgrade!
Thank you for your efforts!

1 Like

Thanks @wakecarter that had me going for a couple of days now.
P.S. Nice UI in the new version.

1 Like

2 posts were split to a new topic: psychoJS.shelf.counterBalanceSelect is not a function

Hi, has there been a follow-up on this? I am having a similar issue.
I was running a study ending with an embedded survey from prior to the update, and I had to correct a typo in the survey a few days ago. Now I just realized that I am missing the data from tall the participants that took the experiment after that - they don’t even show up as aborted sessions… I assume the same thing happened as for AKZ, but I am surprised that it didnt even upload the data.
Is there any way to retrieve them?

Can you update your PsychoPy to 2024.1.1 (or 2024.1.2 in a day or two)?

Would it not affect the experiment?

Ok I have updated to 2024.1.1 and it seems to be okay.
Is there anything that can be done about the lost sessions? It seems like they are still “running” - on the pavlovia dashboard, it says the experiment has 92 sessions, but when looking at the results, it only shows 78.

I’m pleased to hear that the update was successful. I’ve just been chatting with Alain and came to the conclusion that, unfortunately, it wouldn’t be practical to make new surveys compatible with pre-2024 PsychoPy.

The participants who got stuck when your survey updated to the new version won’t have been able to complete, so their data won’t have been saved. You might have their survey data in the survey tab on Pavlovia and, if you have incomplete results saving turned on then you might have the PsychoPy data up to the point they were blocked, but if you can’t find it when you download results then it isn’t available to be found.