psychopy.org | Reference | Downloads | Github

Unknown resource - xlsx file. Have tried adding to Additional Resources

URL of experiment:
https://run.pavlovia.org/jane.garrison/test3/html/?__pilotToken=c74d97b01eae257e44aa9d5bade97baf&__oauthToken=e6311a6273fac6630d0fcbcfa8308b64bab9703f383662209b74d20de5dd5a91
(If this link does not work then please can you give me instructions on how to make it “public”?)

Description of the problem:
I am getting the (seemingly common) error of “unknown resource”:

Unfortunately we encountered the following error:

when importing condition: Stimuli Sheets Auditory/APracticeStudy.xlsx
when getting the value of resource: Stimuli Sheets Auditory/APracticeStudy.xlsx
unknown resource
Try to run the experiment again. If the error persists, contact the experiment designer.

This is a simple Builder project with no code

I have tried the suggestions that have been made elsewhere - ensuring no spelling errors, not confusing / and \, and entering the resource in the Experiment Settings / Online - Additional Resources section (I have also entered the paths to the .wav files that are referred to by the spreadsheet). I have tried using a different path with spaces replaced by _ and still get the error

This experiment worked pre-pandemic. I recently updated Psychopy and now I consistently get the “unknown resource” error. I have tried restoring the old version of Psychopy from Time Machine, but still get the error

You may need to delete and recreate the online version to stop using the html folder.

Thank you for the suggestion @wakecarter

Here’s what I did:

  • shut down Psychopy
  • copied the project folder
  • deleted everything (including hidden files) apart from the .psyexp file and the associated resources it needs (.xlsx, .wav etc) in the existing folder structure
  • started Psychopy and opened the new .psyexp
  • sent the experiment to Runner
  • ran the PsychoJS task in local debug mode - it failed. (First time no local server connection, subsequent I got shown a screen with the option of listing /lib)
  • ran the PsychoJS task from Pavlovia - nothing happened
  • went back to Builder and ran the study online (with Pavlovia). Got the “not piloting” error, so went to Pavlovia Dashboard and enabled Piloting and ran the Pilot on the new project
  • got the same “unknown resource” error as before
  • I went back to Builder and tried running locally again.I got the same “unknown resource” error as before

I am at a bit of a loss as to what to try next. Do you have any other suggestions?

I checked, and confirmed the Additional Resources contains all the .xlsx files and .wav files they refer to.

Here is the new project - AV1 [PsychoPy] in case that helps

This is an odd list of steps.

What I did a couple of days ago when faced with this issue was:

  1. Downloaded existing data from Pavlovia.
  2. Deleted the project from Pavlovia.
  3. Closed PsychoPy.
  4. Deleted all local files and folders from the experiment apart from the psyexp file and resources.
  5. Opened the psyexp file in PsychoPy.
  6. Checked that the output path in Experiment Settings was blank.
  7. Pressed the sync icon to create a new project online.
1 Like

Many thanks, That worked.

I wonder if the critical step was #6 - the output path had “html” in it, and was about the only thing that I hadn’t tried changing to date.

Thanks again for your help.

It seems to have to do specifically with this part of the solution. I used to like the tidyness of having the HTML exports in a subfolder and in Oct 2020 this was no problem for Pavlovia yet.
If the output path is empty, no additional folder “resources” will be created by PsychoPy. Apparently, Pavlovia doesn’t look for the resources in the resources subfolder anymore?

Anyway, thanks for the solution!

You could put your resources in a folder. There are only 3 files created for online so it’s not too untidy in the root.