Pavlovia does not run pilot (Error unknown resource Excel file)

Description of the problem:
PyschoPy experiment works fine offline and can read ‘conditions’ stored in main folder, where the psyexp file is stored as well. The excel document holding the correct answers is called ‘Lextale_English_stimuli.xlsx’


Try reattaching the Excel file to your loop. It is currently trying to find it on your desktop (which will always fail when running online).

I would also discourage you from having your Experiment folder on your desktop. Put it in your documents folder.

How do I reattach this to my loop so it picks up online? Do I do this with PyschoPy and how?

Sorry, I’m new to all of this. As for the moving of the ‘Experiment’ folder to documents; I’m afraid if I do this, it will still look for the root folder on my desktop (which then isn’t there anymore)

Go to Builder

Double click on the loop

Click on the folder icon to attach the spreadsheet. Check the name doesn’t start with …/

Click OK

Sync with Pavlovia by pressing the sync icon

Use Ctrl shift R or an incognito tab to run the latest version online

It works! Thank you so much!

Any idea if this can detach again in the future and/or if I need to have PyschoPy open now it’s running online?

Also, if I ask participants to do the experiment via the recruitment link, where exactly does it keep the results (Excel file)?

Why would you want to detach the Excel?

No, you don’t need to keep PsychoPy open for the online version to work.

1 Like

The data files for participants recruited online will automatically download to the local data folder when you press the sync icon in Builder, so long as you are using CSV data saving instead of database.

I received the CSV data in my data folder. It does turn out like this for one paricipant:

compared to the general overview that I need (see picture 2)

That sometimes happens to me – try different ways of opening the file. Specifically I find that if I open a file and then save it, I get this if I don’t specifically choose to save it as a csv file.

1 Like

If I import the csv file onto a new excel sheet, it lets me divide the columns where there are commas. That solves my problem! Like you said: a matter of opening the file.

1 Like

Sorry for bothering again. I opened the Csv file like you said but once I want to calculate the average respond time in my pivot table of a participant (column E), my number ends up way bigger than it is (I presume because Excel erases my “.” automatically).

As you can see, all numbers not starting with “0,…” have this problem and these are also recognized as “number” whereas the ones starting with “0,…” are recognized as “Standard”

Thank you in advance.

The ones starting with 0 are the problem — they are being interpreted as strings. Does this post help?

You mean overriding the column with the a copy from the text editor? Unfortunately, this does not work. Is there another way to turn these strings into numbers? I’ve already tried Text to Columns

Please could you upload a sample data file so I can see for myself?

Voorbeeldstudie_Niels.xlsx (22.6 KB)

The column I want should look more like this:

How about this?

I copied the column into a text editor, pasted it back into a new column and then divided by 1000 for the RTs over 1.

I think the issue is with your Excel thousand and decimal separators.

0.123 is being interpreted as text but 1.234 is being interpreted as 1234

Voorbeeldstudie_Niels.xlsx (23.3 KB)

Hi Wakecarter,
I have been having the same problem with my experiment.This is not my first experiment on Pavlovia and I haven’t had problems before. I have followed the steps you mention, but no luck. I am using Psychopy version 2021.2.3. I have tried solutions given here, here, and here. Nothings seems to work. I’m at my wits end!
Can you help out? Link to my project.

Please could you show a screenshot of your error message?