| Reference | Downloads | Github

Unknown resource error regarding to conditions file

URL of experiment:

This program was made using the standalone PsychoPy v3.2.3. After presenting the instruction, an image and rating scale should be presented. This program works properly as an offline program.

Description of the problem:

After presenting the instruction, the following error appears.

Unfortunately we encountered the following error:

  • when importing condition: conditions.xlsx
  • when getting the value of resource: conditions.xlsx
  • unknown resource

Try to run the experiment again. If the error persists, contact the experiment designer.

It seems that the program could not find the conditions.xlsx although it was saved in the resource folder. The conditions.xlsx includes the image file names.

Best regards,

It looks like you’ve simply uploaded this to your own server and tried to run it? That won’t work because the experiment needs a way to communicate with the server to fetch resources files. Try pushing to Pavlovia instead.

Thank you for a reply.
I think you are correct, but unfortunately, I can not test what you suggest because I have no Pavlovia Credits/License now.

It’s OK. Please treat this topic as closed.

You can use Pavlovia to test your experiments without having any credits. You just set your experiment to “piloting” mode, and run it as many times as required, without cost. It is only when you actually want to collect data from participants that you need to switch to 'run" mode and have a positive credit balance.

Thanks @Michael, but I ran into the problem which is described in this topic Error piloting experiment on pavlovia

If you have any suggestions, let me know please.

This sounds like a question for @dvbridges or @apitiot I’m afraid…

Im facing a similar error but I am unable to fix it. Can you help?

Go to your dashboard on Pavlovia and click on the button to Pilot each time you need it. Pilotting doesn’t currently allow you to load the experiment from a URL (or from within PsychoPy), which I guess is what you’re doing.

Hi! Thank you for your prompt response. The error I am now getting is this:

I have tried the solutions mentioned on this page but nothing works.