psychopy.org | Reference | Downloads | Github

Online experiment "Unknown Resource" issue

Hi There,

I am having a similiar problem on the pavlovia platform, however my error is with regards to the use of a .csv file for conditions.

Psychopy version - 3.07
Windows version - 10; 64 bit

Description of the problem :

I have designed a basic trial version of a change blindness flicker task that runs fine on my local Desktop. After uploading & activating on pavlovia to test functionality, the resources load accordingly and the experiment starts. On the first trial I am presented with the following error:

All the required file paths appear in GitLab

Conditions are used in the following way:

  1. Block Select.csv directs the experiment to pick one of four blocks
  2. trial select is used to randomly load individual trials

[see image below]

I have tried changing the file paths to include html\resources but this made no difference.

Any advice would be thoroughly appreciated!

Kind Regards,
Maxwell Murphy

Hi @Max_Murphy, we added a fix for this in PsychoPy 3.1.0. I believe the problem relates to the use of backslash in the JavaScript to find your conditions file. Try changing the path manually to use ‘/’ in condition path in your loop.

Thank you for the prompt reply, I’ll give that a shot, cheers!

I’m having the same problem I tried the solutions above mentioned but it still doesn’t work. By the way, the real name fo my file is ‘1back.xlsx’

image

Hi all, I am having a similar issue, however I checked and the appropriate .mov files are in the HTML folder. Any suggestions? The experiment code is under adult_goldilocks_exp1 Screen Shot 2020-04-16 at 10.30.36 AM

Check here Movie clip doesn't work

Hi I am facing a similar error with regards to my .csv file and the path includes a ‘/’ but it still won’t work. Can someone help???

Well, let’s try and debug that. Is there anything different about instructionList.csv compared with conditions files normally (given that normally they do load)? Maybe this is defined by a code snippet rather than explicitly named?

No, I have a file that is explicitly named instructionList.csv. All the other .csv and .jpg files required for the experiment are in the html folder on Gitlab. All files do normally load and there seems to be nothing different about the instructions list. In total, there are 2 sets of instructions in the instructionList.csv file. I have it set up such that one set of instructions is randomly administered.

Hi,
I am having exactly the same problem. No one of the proposed solutions works.

Thanks
Fra

1 Like

I also have the same issue - the experiment is able to load all .bmp files when I run it offline, but only three out of four images when I run it online, with the same error code as others are getting here. All images are in the same place (the main Pavlovia folder) and I also tried reuploading. I can’t see any difference between the images.

Actually scratch that - the image file wasn’t in the html repository. I added and it works now. I don’t fully understand why all images didn’t upload to the same place though.

I am glad for you! However my problem is with uploading the Trials_List.csv file. I have tried to add it to the htlm forlder ( and i any other folder), and still not working.

Have you tried html/resources?

1 Like

BMP files aren’t ideal for online. PNG is probably the best lossless format

Good shout. Francesca, did you try the resources folder? If not, could you try deleting the experiment on Pavlovia and re-uploading? See e.g. Create new experiment from existing file

Hi all,
I managed to solve the problem by uploading resources trough the prompt. For some reason, the sync options doesn’t work properly with me. But more in general I have issues with pychopy when it has to refer to .csv or -xlsx condition files.

I have the same problame and I tried to change the names. Could you pls help me?

this is the massage I get:

image

the name of my experiment is HIS1

I can’t find your paradigm on pavlovia, but i think your resource files aren’t loaded correctly at the beginning. (I also had this problem)
Deactivate your project, empty your browser cache (just to be safe) and activate it again. If this isn’t the solution you can delete your whole project online and upload it again with a different name.

Can you also share a screenshot of the welcome screen, where the resources are loaded?