Unable to start experiment on Pavlovia if I use PsychoPy 2020.2.3, unable to break loops if I start experiment on 2020.1.3

Hi everyone on psychopy! :slight_smile:

I’m currently facing 2 problems.

  1. I tried running my experiment on PsychoPy 2020.1.3 and it runs perfectly fine locally. I then tried running it online on Pavlovia, but the loops would not break and I am unable to get past the first practice trial block actually.
    This is my current loop code.

I’ve tried to change my code to whatever that was suggested here: Builder - terminating a loop — PsychoPy v2021.2, but to no avail. The experiment either does not recognize the loop, or prematurely jumps to actual trials.

Attached is the link of my experiment, when run on 2020.1.3.

URL of experiment: Pavlovia

  1. I then tried recreating this experiment on 2020.2.3 instead, hoping that it might fix the loop error. However, now, the experiment doesn’t even run locally. In fact, when I try compiling the code for this current experiment, this was what I got:

While trying to run the experiment on Builder, it appears that the app made a force exit for the experiment, as I got such a message instead:

Attached is the URL for the experiment when conducted on 2020.2.3.

Was wondering why this is the case for these 2 problems - sorry for the inconvenience but I’m really at a loss regarding these :frowning: I need to start data collection ASAP too, would appreciate any advice on this, thank you PsychoPy community!