Unable to break loops on Pavlovia

Hello everyone on Psychopy Discourse! :slight_smile: I have a question to ask you guys about my online experiment.

Description of the problem:
My experiment can be run on PsychoPy, but the problem was that the loops did not work on Pavlovia.
I’ve tried to change my code from the “Begin Routine” tab to the “Each Frame” tab, but to no avail.
This is my current code, which worked fine on PsychoPy:

I’m at a loss on what to do but am relatively new to PsychoPy. Would really appreciate help on this, I need to start data collection ASAP :frowning: thank you so much and sorry for the inconvenience!

Attached is the URL of my experiment: URL of the experiment: Pavlovia

Your js-file in the html folder indicates that you are using psychopy version 2020.1.
In that version you were only able to break the loop with

trials.finished = true; 

independent of the actual name of the loop. And breaking the loop was difficult with nested loops (see https://github.com/psychopy/psychojs/issues/68).

In the 2020.2 release you would be able to break loops by using the name of the loop (as u did in your code). See the “CHANGES” section in the changelog (https://www.psychopy.org/changelog.html).

Therefore you could either update psychopy or change your code to trials.finished = true;

While running on the Pavlovia, I am getting an error: “unknown thisN”

I am using the PsychoPy 2020.2.3.

Hi Kim,

By changing my code to trials.finished, what does the “trials” refer to?

Sorry if this appears to be an obvious question, but I’m new to psychopy and am learning things on the way.

Thank you!

“trials” was simply a placeholder to use instead of the actual name of the loop. It still referred to the loop but without calling it by its name and without differentiating between the different loops if they were nested.

Btw. did you manage to solve your problem?

Thank you Kim for the clarification!

No unfortunately :frowning: - I tried running the experiment on the newer version of PsychoPy like u suggested (version 2020.2.3) and even recreated it too. However, the recreated version doesn’t run locally on my computer even :frowning:

Hence, was wondering if you have any advice on this?