psychopy.org | Reference | Downloads | Github

Unable to run experiment, result in a freezing screen and unable to shutdown

Im currently using PsychoPy 2020.2.4 version


When i tried to run experiment, this screen shown and nothing happened. I was unable to even close the screen, even with task manager on.
I was just trying to run inputText experiment exactly like this : inputText [PsychoPy]. Back then i used to able to run stroop task easily, but after this error i was unable to run any experiment.
Here is my laptop information, since i dont know if it is a system error or not.
ASUS S400, core i5 1.7GHz 4CPU, Intel HD Graphics 4000 card, Windows 10.
Thanks a lot in advance. It would be great if you guys able to figure out what to fix, but any hints on what I should check is greatly appreciated.
Edit : I run stroop task and left the screen for 3 hours, and this is the log of the IDE.

Running: C:\Users\ASUS\Desktop\PsychoPy3 Demos\stroop\stroop_lastrun.py

pygame 1.9.6
3.0064 WARNING We strongly recommend you activate the PTB sound engine in PsychoPy prefs as the preferred audio engine. Its timing is vastly superior. Your prefs are currently set to use [‘sounddevice’, ‘PTB’, ‘pyo’, ‘pygame’] (in that order).
8.2838 WARNING Font Manager failed to load file C:\Windows\Fonts\VPRESENT.TTF
15.2648 WARNING User requested fullscreen with size [2560 1440], but screen is actually [1360, 768]. Using actual size
69.0341 WARNING t of last frame was 4303.44ms (=1/0)
73.3477 WARNING t of last frame was 4313.64ms (=1/0)
77.6573 WARNING t of last frame was 4309.65ms (=1/0)
81.9633 WARNING t of last frame was 4305.93ms (=1/0)
86.2663 WARNING Multiple dropped frames have occurred - I’ll stop bothering you about them!
491.5067 WARNING Couldn’t measure a consistent frame rate.

  • Is your graphics card set to sync to vertical blank?
  • Are you running other processes on your computer?

965.4913 WARNING Couldn’t measure a consistent frame rate.

  • Is your graphics card set to sync to vertical blank?
  • Are you running other processes on your computer?

Alert 4052:Experiment was built in a past version of PsychoPy (3.0.1), saving it in this version may add parameters which cannot be parsed.
For further info see https://psychopy.org/alerts/4052.html

Experiment ended.

1.8277 WARNING We strongly recommend you activate the PTB sound engine in PsychoPy prefs as the preferred audio engine. Its timing is vastly superior. Your prefs are currently set to use [‘sounddevice’, ‘PTB’, ‘pyo’, ‘pygame’] (in that order).
5.1558 WARNING Font Manager failed to load file C:\Windows\Fonts\VPRESENT.TTF
16.9550 WARNING User requested fullscreen with size [2560 1440], but screen is actually [1360, 768]. Using actual size
69.7941 WARNING t of last frame was 4301.98ms (=1/0)
74.1073 WARNING t of last frame was 4313.18ms (=1/0)
78.4091 WARNING t of last frame was 4301.83ms (=1/0)
82.7253 WARNING t of last frame was 4316.26ms (=1/0)
87.0443 WARNING Multiple dropped frames have occurred - I’ll stop bothering you about them!
492.0327 WARNING Couldn’t measure a consistent frame rate.

  • Is your graphics card set to sync to vertical blank?
  • Are you running other processes on your computer?

965.8878 WARNING Couldn’t measure a consistent frame rate.

  • Is your graphics card set to sync to vertical blank?
  • Are you running other processes on your computer?
Experiment ended.

It looks like there may be some process running on your PC which is taking up a lot of graphics memory, maybe a memory leak somewhere? This isn’t my area of expertise I’m afraid

As for the inputText demo, we actually have an editable Textbox component (:textbox:) now, so if you manage to fix this issue I recommend switching to that rather than manually coding editable TextStim components.

Thanks you for the response!
I happened to come across this thread with similar problem like:

I have tried to reinstall the older version that i used to run (3.1.5), change useFBO to False , disable other python environment, and it is still didnt fix it, as well as same kind of error
The best i could manage is the exp is able to display the 1st screen, but wont able to press any key and the runner is in constant not responding mode . Which is very weird since i have seen older graphic card worked with even the newest version, and some of the previous report have better graphic than mine yet still face this error.

I also have to collect data soon, but i dont know any alternative way other than trying to run on older version, so any suggestion for me to design and run exp atm is also welcome.
Thanks!
Small update : I tried to change expInfo[‘frameRate’] to a fixed 60, it still opened extremely slow, but i was able to run a few screen of stroop task in a very slow fashion, and it crashed after 5 mins.