Unable to push experiment to Pavlovia; unsafe repository

URL of experiment: DFREP_CS [PsychoPy]

Description of the problem: I am trying to push a new version of my experiment through PsychoPy on my computer to Pavlovia online. I receive an error when I do this (pasted below) regarding an “unsafe repository”. I pushed updates to Pavlovia just last month and did not receive this error. Additionally, I ran the git config call recommended at the end of the error and it did nothing to solve the problem. Anyone know what’s going on here?

Traceback (most recent call last):
File “/usr/local/lib/python3.6/dist-packages/psychopy/app/builder/builder.py”, line 1350, in onPavloviaSync
retVal = pavlovia_ui.syncProject(parent=self, project=self.project)
File “/usr/local/lib/python3.6/dist-packages/psychopy/app/builder/builder.py”, line 1441, in project
elif self.filename and pavlovia.getProject(self.filename):
File “/usr/local/lib/python3.6/dist-packages/psychopy/projects/pavlovia.py”, line 1082, in getProject
for url in remote.urls:
File “/usr/local/lib/python3.6/dist-packages/git/remote.py”, line 553, in urls
raise ex
File “/usr/local/lib/python3.6/dist-packages/git/remote.py”, line 529, in urls
remote_details = self.repo.git.remote(“get-url”, “–all”, self.name)
File “/usr/local/lib/python3.6/dist-packages/git/cmd.py”, line 545, in
return lambda *args, **kwargs: self._call_process(name, *args, **kwargs)
File “/usr/local/lib/python3.6/dist-packages/git/cmd.py”, line 1011, in _call_process
return self.execute(call, **exec_kwargs)
File “/usr/local/lib/python3.6/dist-packages/git/cmd.py”, line 828, in execute
raise GitCommandError(command, status, stderr_value, stdout_value)
git.exc.GitCommandError: Cmd(‘git’) failed due to: exit code(128)
cmdline: git remote get-url --all origin
stderr: ‘fatal: unsafe repository (’/media/datadrive/PsychoPy_Experiments/DFREP_CS’ is owned by someone else)
To add an exception for this directory, call:

git config --global --add safe.directory /media/datadrive/PsychoPy_Experiments/DFREP_CS’

It appears this issue is linked to a new security update in the new version of GitHub. I updated Github on my computer, and then the git config command worked and I was able to push my experiment.

More here: `fatal: unsafe repository (REPO is owned by someone else)` with ubuntu 20.04 container · Issue #760 · actions/checkout · GitHub

EDIT: I thought this fixed this issue but I am still unable to push the experiment. Gitlab says I may need an SSH key? Does PsychoPy need to be updated to deal with this issue?