Possible trouble pushing study to Gitlab repository

I have previously ran a pilot online using Pavlovia, worked very well. I now want to conduct some further piloting using a new version of the pilot. This version has come from me ‘saving as’ into a new folder (I deleted previous online elements from study such as hidden git folder and just left .exp in folder along with usual resource folder, data etc) and have been making improvements for some time now on this pilot v2. It now runs offline with no issues. However, when I try and upload to Pavlovia I get the following error after logging in, providing description of changes to study etc.

Traceback (most recent call last):
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\builder\builder.py”, line 1374, in onPavloviaSync
pavlovia_ui.syncProject(parent=self, file=self.filename, project=self.project)
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\pavlovia_ui\project.py”, line 787, in syncProject
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\pavlovia_ui\sync.py”, line 47, in sync
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\projects\pavlovia.py”, line 800, in sync
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\projects\pavlovia.py”, line 982, in firstPush
info = self.repo.git.push(‘-u’, self.remoteWithToken, ‘master’)
File “C:\Program Files\PsychoPy\lib\site-packages\git\cmd.py”, line 638, in
return lambda *args, **kwargs: self._call_process(name, *args, **kwargs)
File “C:\Program Files\PsychoPy\lib\site-packages\git\cmd.py”, line 1183, in _call_process
return self.execute(call, **exec_kwargs)
File “C:\Program Files\PsychoPy\lib\site-packages\git\cmd.py”, line 983, in execute
raise GitCommandError(redacted_command, status, stderr_value, stdout_value)
git.exc.GitCommandError: Cmd(‘C:\Program Files\PsychoPy\MinGit\cmd\git.exe’) failed due to: exit code(1)
cmdline: C:\Program Files\PsychoPy\MinGit\cmd\git.exe push -u Sign in · GitLab master
stderr: 'warning: redirecting to Sign in · GitLab
fatal: the remote end hung up unexpectedly
fatal: the remote end hung up unexpectedly
fatal: the remote end hung up unexpectedly
error: failed to push some refs to (hyperlink)

It seems it may be problems connecting to gitlab. As it appears in pavlovia but when i click to see code the repository is empty. Any ideas? Also, to note that the pilot and pilot v2 are saved in different folders.

I also tried updating to newest version to date (2022.2.4) from 2022.2.1 but with no luck. The 2022.2.1 was the version used for pilot v1 that worked successfully. I have also uninstalled 2022.2.1 now.