psychopy.org | Reference | Downloads | Github

Unable to pull data using git pull (last few days only)

URL of experiment: https://run.pavlovia.org/agnes.norbury/online-game/

Description of the problem:
Hi

The last couple of days I have been running into the following error when attempting to pull new datafiles onto my local machine using git pull (the .csv data files show up on the experiment gitlab page, and can be downloaded manually from there, but it would be nice to be able to pull them directly again):

ssh: connect to host gitlab.pavlovia.org port 22: Operation timed out
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

Could this be something to do with the recent server update, or do you think it is more likely to be an ssh permissions error my end? (My local machine is running macOS high sierra v 10.13.6)

Everything has been working beautifully up until now - thanks for all your time and effort building such a greater tool.

Best

Agnes

Ah, I think this is due to a new security policy at Nottingham University, whereby we can only now connect to ssh via a VPN [sigh]. We’re desperately trying to move the server away from the uni so we won’t be beholden to their changes like this.

I think you chould be able to sync using the https address instead, which is what the PsychoPy app will do

1 Like

Thanks so much for the quick response!

I just cloned a new version of the experiment folder using https instead of ssh and can confirm git pull works fine this way.

Best

Agnes

1 Like

Hi, I think I have a similar problem (encountered yesterday), but using https instead of ssh does not fix it. I had originally pushed it to a https git from bash (as per Project isn't syncing to pavlovia, tomstafford’s 18 Dec reply). The experiment still starts up, but after a variable amount of screens/time it just shuts down. (https://run.pavlovia.org/cc99/imagerystudy/html/) I have changed nothing about it since Friday, and it ran just fine then. Also, pushing a demo (mental rotation) from builder to Pavlovia does not work, it hangs on “Synchronising…” - it works fine locally. Any other solutions for this?
Best,
Carlijn

I am also having same problem. I am unable to use the syncing in builder too (you might remember this from the Warwick course). I can create a new repo and sync to it from builder but as soon as I restart builder I get the message that the files are not linked to a project. Any help much appreciated as neither the builder or direct git options are working for me, Thanks, Alice

quick aside ____
Hey Alice, what’s the Warwick course? I’m a beginner programmer so if that’s accessible and you can recommend it I should probably look into that! Thanks

Hi- it was a one-off course at the Uni - but can definitely recommend it - if Jon and Dave are running another somewhere and you can go along it’s a great course.

oithat’s tough, I’m based in Amsterdam and New York atm. If there’s any online resources a PM would be welcome!

Hi @jon, this post is marked as solved but I still have these issues unfortunately. Do you have any idea why my exp quit working properly last week? Thanks in advance for your help.

EDIT: it now (partially) seems to be a Safari-only problem: the experiment I made does run OK on Chrome.
The mental rotation demo still doesn’t work on Chrome, and now gives this error (it doesn’t in Safari).

When I try to debug my experiment in Safari, it actually freezes the screen and I can’t look into any problems further. Even when I try to go to a different page, the screen stays frozen on top of the new webpage - so something is definitely up. That looks like this:

So, in summary: there’s two things. 1 - running a perfectly fine experiment on Safari now no longer works (since last Wednesday), and completely shuts down the tab/screen it was opened on. 2 - the mental rotation demo doesn’t work on any browser, and doesn’t give error messages in Safari (just a blank gray screen). I understand if this is a dated demo, I’d just like to find out how to make it work/what’s going wrong in pushing it to Pavlovia so I can take it as a format for a new experiment I’d like to get started on.

Thanks so much in advance!!

Hi @jon, just jumping in here.
I am experiencing something similar (I think). I am able to upload my experiments but the website that opens then contains an old version of my experiment (of 25 june).
I am quite puzzled as to why this is as I have deleted all previous versions of my experiment from the folder I upload (as well as from my github), and even created a new pavlovia account. Could this be related to the new security policy at Nottingham as well?

These various reports are all about different issues and really need their own threads or they get ignored. The original post is about an inability to pull data (or push experiments) from the command line, caused by a security change preventing git ssh.

The PsychoPy app wasn’t using git ssh anyway (it used https) so sync from the app should not have been affected.

Issues with experiments that aren’t working need to be raised in their own posts where we can then investigate those experiments. They will be lost in this solved post about git ssh.

@am8302 your issue is quite close to this but not the same and I’d like to work out what’s going on with that but that is something that seemed specific to your machine and we’ll need more info to work out the issue. I wonder if it’s some security setting on the laptop but, again, I think it would be better discussed in its own thread

Hi Jon,

I would add to this thread because I had the same problem (I could not pull/push/clone) and the https fix worked (Thanks!). HOWEVER, I will note that this problem seems to have only affected repositories of experiments that were created before some date. A project that I created on July 28th, 2019 did not suffer from this issue at all (push/pulls just fine). A bit confounding when searching for an explanation :slight_smile:

Cheers,
Damian