psychopy.org | Reference | Downloads | Github

Standard Error Issue while first push to Pavlovia

Hi all,

While being at the workshop with @Becca , and trying to push my experiment to Pavlovia, I encountered SSL error, and even after looking into it, we weren’t able to find a solution. So as per her instructions, I am attaching the error here so that it could be dealt here. The error:

Pushing files to Pavlovia
Pushing to Pavlovia for the first time...Traceback (most recent call last):
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\pavlovia_ui\project.py", line 497, in syncProject
    project.firstPush(infoStream=syncFrame.syncPanel.infoStream)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\projects\pavlovia.py", line 822, in firstPush
    info = self.repo.git.push('-u', self.remoteWithToken, 'master')
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\git\cmd.py", line 548, in <lambda>
    return lambda *args, **kwargs: self._call_process(name, *args, **kwargs)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\git\cmd.py", line 1014, in _call_process
    return self.execute(call, **exec_kwargs)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\git\cmd.py", line 825, in execute
    raise GitCommandError(command, status, stderr_value, stdout_value)
git.exc.GitCommandError: Cmd('C:\Program Files (x86)\PsychoPy3\MinGit\cmd\git.exe') failed due to: exit code(128)
  cmdline: C:\Program Files (x86)\PsychoPy3\MinGit\cmd\git.exe push -u https://oauth2:54682833666cc0ed40affacaedcb7d48733d8e94a0f0e13e520bf8b331c48a7d@gitlab.pavlovia.org/TheShane/cep_posner_feb18.git master
  stderr: 'fatal: unable to access 'https://oauth2:54682833666cc0ed40affacaedcb7d48733d8e94a0f0e13e520bf8b331c48a7d@gitlab.pavlovia.org/TheShane/cep_posner_feb18.git/': OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to gitlab.pavlovia.org:443 '

Any help would be appreciated. Thanks!

Hi Shardul,

Thanks for sharing this here - I actually noticed that the previous post I was reading was also from yourself ! JavaScript - continueRoutine = false -- problem online - #55 by Shardul_Shankar

Could you please provide the zip file on this post too so that we can look at it more?

Thanks,
Becca

Hi Becca,

Yeah, I’ve had this problem for a long time. Since I had a comparatively bigger experiment set to create for my Ph.D. thesis, I thought of tackling that first, and hence wasn’t actively looking for the solution for this issue. So thank you for the workshop, as it brought it back to my list of issues to deal with. :slight_smile:

Also, this portal is not providing the option to upload a zip file. What else or where else can I upload it?

Hi @Shardul_Shankar, sorry could you confirm you are not trying to connect behind a firewall or proxy? It looks like git is having problems authenticating your account against Pavlovia, thanks, s.

Hi @sotiri ,

Thank you for responding. In my institutional system, I do try and connect through a proxy. But through my home system, there is no such thing.

But this error is through the proxy.

Hi @Shardul_Shankar, gotcha, OK there should be a git setting to help with that, please could you try something along the lines of?

git config --global http.proxy myproxy.com:8080

Hi @sotiri ,

I tried your instructions and ran it on my cmd. This is the error that came up:

'git' is not recognized as an internal or external command,
operable program or batch file.

I tried to look through Program Files and Program Files (x86), and it appears there is no git folder available. This is probably why Environment Variable is not getting added? This is even weirder and probably out of my expertise.

Hi @Shardul_Shankar, OK according to the error trace you posted, the path to PsychoPy’s git executable on your machine should be C:\Program Files (x86)\PsychoPy3\MinGit\cmd\git.exe

That worked like a charm! But new error popped up:

Synchronising...
Pushing to Pavlovia for the first time...
Branch 'master' set up to track remote branch 'master' from 'https://oauth2:54682833666cc0ed40affacaedcb7d48733d8e94a0f0e13e520bf8b331c48a7d@gitlab.pavlovia.org/TheShane/cep_posner_feb18.git'.
Success!
Successful sync at: 18:32:36, took 3.034s

And on output window, this was the error:
25.0038 ERROR [WinError 267] The directory name is invalid: 'D:\\psychopy_examples\\builder\\posnerTargets\\posnerTarget.js'

Even though there is a js file with the name in the folder.

Also, there is success shown on the sychronising screen, but there is nothing on the Pavlovia dashboard.

Right, I was able to figure out some of the issues here, and re-pushing created the experiment, but now when I ran it, this error came up.

URL of the experiment: https://run.pavlovia.org/TheShane/cep_posner_feb18

OK that just means your resources folder has likely been left out of the commit

Sorry @Shardul_Shankar, do you mind giving me developer access so I can take a look at the repo? Thanks, x

Hi @sotiri, how do I do that?

Ah yes, good question, there should be a members tab for that in GitLab’s experiment settings :blush:

Yeah, reached there, but @sotiri is not showing up. Are you by any chance with a different name on gitlab? Also, Just for cross-checking, this would be the link where I would try and add you, right?

OK thanks, yes exactly, ‘Select members to invite’ should autocomplete, no?

Yeah, but

OK thanks, sorry @thewhodidthis is my username on GitLab

OK thanks, please could you try looking me up by name waiting for suggestions as you type each letter?