Gitlab pavlovia is not responding

I am expriencing problems when trying to synchronize psychopy experiments to pavlovia.
I have the impression that the GitLab server is down… also because I cant easily access to it from the browser ( => Whoops, GitLab is taking too much time to respond).
Do you have similar issue? Thanks!

Hi, I’m also having trouble accessing gitlab at the moment. The whole Pavlovia interface seems to be running quite slowly, and there may have been a problem when a participant tried to run an experiment session - will update when I hear back from them

Same impression.

I can run existing experiments… but it’s extremely low in charging the resources at the beginning of the experiment (it takes around 30 seconds, normally it take few milliseconds).

[1] Synchronize PsychoPy experiments to Pavlovia ( PsychoPy gave me similar errors mentioned by ArchAngel - Experiments not syncing/uploading with/to Pavlovia

[2] Access to “” platform. The server returns me the errors 502 (“Whoops, GitLab is taking too much time to respond”) and 503 (“The service is currently unavailable”)

Please, help here is more than welcome :slight_smile:

Also downloading existing datasets seems to be complicated

I managed to download data files, but it took two tries. I also confirmed that a participant was able to open and complete the study, the data was saved (as in this post), but they were not routed to the next portion correctly. I suspect that there is an error because participants have messaged me saying that they experienced an error, but I haven’t received exact error messages or screenshots. This has happened a few times (not all the time, and not even close to a majority of the time) over the last few days.

1 Like

I can also report that I had trouble pushing changes. Downloads switching to code view just about everything is very slow.

We are facing similar issues. Our participants do also (not consistently, but frequently) report that they complete the experiment and are not forwarded, get a 504 - Bad Gateway or the message that their data could not be uploaded.
Could it be that there is an issue with the gitlab instance?

I am also having a similar problem with both downloading existing data and studies not completing, details below:

19/04 we tried running participants in 3 different studies - the first participant went fine but the subsequent participant in that same study (+ two attempts for two different studies) returned a 504 error after the participant finished the study. Resources seemed to load fine for all participants and it seems the error is related to pushing the data to the server (as all 4 credits were consumed but 3 of those are considered as incomplete and/or aborted despite all participants finishing the study)

20/04 there were no issues with running (different studies but same account) but was given a different 504 when trying to download the database from one of them afterwards (Pavlovia still seems to be trying to fetch these data after 2+ hours). Now when trying to run the studies from 19/04 (later today) we are again receiving the 504 errors

Both errors come from nginx so it seems to be a server issue

See also:

Hi, I am also experiencing problems with synching experiments. At first I got an error message “failed to push some refs to etc.” now I get

Pulling changes from remote…
Already up to date.
Pushing changes from remote…
Successful sync at: 17:39:05, took 6.923s

although I have modified the file (and the online experiment has not changed). I encountered the same problem this morning and I solved by creating a new project, but this is getting annoying because it makes connecting the databases overly complicated.

@MBrede I’m not sure what’s happening but I hope that someone who is officially associated with Pavlovia can provide some information. (I recently submitted a request via a site feedback tag on the forum because I don’t know how to officially contact someone from the team if there’s a problem).