Push/pull commands in terminal prompt for password


Whenever I use the terminal to push/pull changes in my experiment from my desktop to Pavlovia and vice versa, the terminal prompts me for ‘git@gitlab.pavlovia.org’s password’. Using my Pavlovia password does not work here, and after trying three times I am met with the following error:
‘fatal: Could not read from remote repository.
Please make sure you have the correct access rights and the repository exists.’

As far as I am aware, I have an SSH key set up properly. The problem suddenly started occurring today, and I did not change anything in the set up of the SSH key prior to the error occurring.

Same issue here. It seemed to show up today, I was able to push/pull with no problems as of last Friday.

Same here. Worked two days ago, now it’s an issue.

Same issue here. Worked a few days ago.

Tried resetting ssh key and changing password - error persists.

Also worth noting that the gitlab.pavlovia.org page was down a few times today. Possibly unrelated, given that the error persists even when the page is up (as it is now), but still worrying.

Same here - the last I was able to push was 5 days ago.

Ah, I think this might be related to a (possibly over) tightened security measure where we blocked most of SSH access. Can I just check are you all using SSH to communicate with gitlab rather than HTTPS? PsychoPy itself uses HTTPS so most users would have noticed no difference but if you’re all doing git push/pull via terminal then I know what the problem is

Regarding the page being down I wasn’t aware of that but we were having a company perform “penetration testing” yesterday and today and maybe that caused some issues.

That would be a most probably cause indeed!
I’ve relaxed the ssh constraints. Let me know if the issue persists!


I see! I was indeed using SSH to communicate to GitLab. I am now able to use the terminal to make changes to my experiment again, so relaxing the constraints seems to have worked. Thank you both for fixing this so quick!

I am very glad. My apologies for the mishap. Hell, as they say, is paved with good intentions…


yep, solved it for me too.

Hi, just came across this post after having the same issue today.

I am using git via push/pull over the terminal, since I never got it to work over psychopy on linux.

Any chance SSH has been constrained again as previously?