| Reference | Downloads | Github

Unable to download resource, FILE_LOAD_ERROR

While we would need the project to be public to pilot it or view the code, it doesn’t need to be public to run or for the owner to pilot.

1 Like

@wakecarter @JensBoelte I just made it public! I just changed the path, but seemed to have the same issue still

I spot a backslash in that path

1 Like

What ended up being the original problem? I’m having a similar problem where I made a small edit and now no resources can load on Chrome.

What does your error message look like?

This is when I try to pilot: “unable to download resource: webgazer.js (FILE_LOAD_ERROR)”

However, I think it has something to do with my browser and cookies, because clearing cookies and testing it in an incognito window sometimes works. Although I’ve gotten messages for other resources that fail to load (e.g., images and Excel files). None of this seems to happen when opening it from a new computer with no history of the experiment (e.g., a participant).

I am facing the same error. I had created this program in an older version and have now updated Psychopy to the latest version. Do you know how to resolve this error? Thank you so much!

Have you attached the resources in Experiment Settings / Online ?

Yes. I never encountered this error in the previous version. This code was written and up and running in the older version. But, to resolve the traceback error, I installed the latest version and now I am getting this error. The files are not getting downloaded (Attached in the images) and then the unknown resource error.

Please could you upload a screenshot to show that you’ve done this step. Your reply isn’t clear on this point.

Here’s the screenshot. ‘image’ variable is part of an excel file which is also included in the resources.

What version of PsychoPy are you using? I note that your output path is html (which isn’t recommended any more). Versions 2020.2.1-4 had an issue with the connection of the additional resources. However, you could try manually copying the files to html/resources.

html/resources contains all the images that I used in the program. I used version 2021.1.3 to make the program and then I updated to version 2021.2.0. After this update, I started getting this error. Is there anything else that I can do?

@TParsons Might there be a new error in 2021.2 which means that “Additional Resources” doesn’t work with a specified output path?

I reinstalled the version 2021.1.3 and its working great! Thanks again!

That seems the best explanation, I’ll confer with the JS team to see what’s going on - the key question is whether Builder is sending the wrong file paths to Pavlovia or whether Pavlovia isn’t reading them properly. Either way this is a priority so you can expect a fix in 2021.2.1 :slight_smile:

Probably 2021.2.2 unless you have a time machine.


Oops yep, forgot we were on .1, it would be .2 :slight_smile:

I installed the latest psychopy version 2021.2.3 and still have the same error. Unknown source and files won’t get downloaded.

When you look at the code on the GitLab for your experiment, is the file monash-logo-mono.png there?