psychopy.org | Reference | Downloads | Github

Two experiments running perfectly yesterday now present an “The next task has unknown type (neither a scheduler nor a Function) “ error

I so the older thread # Pavlovia Run error “the next task has unknown type (neither a Scheduler or a Function)”
However, the full refresh does not solve the problem in this case.

Links of the experiments:

https://pavlovia.org/run/AndreiRazvanCostea/edsc41_in_ex/html/

https://pavlovia.org/run/AndreiRazvanCostea/edsc42_ex_in/html/

This is an ongoing experiment and until a few hours, data from the participants were coming in. Suddenly, I’ve got ‘bombarded’ with messages and print screens such as the one I attach below.

Now the experiments do not run on my machine also, the error appears right after clicking the OK button which says all resources downloaded.

Is there an update going on at the moment? Should I stop collecting data at this time?

I’ll check what’s going wrong

Short update, I tried to upload the psychopy experiment into a fresh repo on Pavlovia – and in this case it throws the attached error. I hope it helps.

If I can be of assistance in any way, let me know John.

I was about to post a similar issue, my test experiment says:

"The next task has unknown type (neither a Scheduler nor a Function)"

Experiment URL:
https://pavlovia.org/run/aendrs/dataval_test/html/

I’m also experiencing the same error messages. i.e same error message from original repo and second error message when I move to a new repo

Try again now. Should be fixed

I’m experiencing the same error. I have tried uploading to a fresh repo, and in doing so, I receive the same error. I will also note that in the last couple of times I’ve tried to push the experiment to a fresh repo to address these issues, when changing to piloting or running on Pavlovia, it has not generated a URL, so I don’t know if that contributes to these issues. I will also note that I recently upgraded to PsychoPy 3.1.2 and am able to run this experiment perfectly on builder but it has not worked when pushing it to Pavlovia (I have limited JS code components that aren’t generated by the exportHTML function and there are no errors when exporting to html from builder)

Hello @alisonmarie526,

Could you confirm whether the error is still occuring? If so, would you mind telling me which experiment you are running?
Best wishes,

Alain