Syncing issues: Pavlovia running old version of experiment (problem wasn't solved by following guidelines of previous posts on this issue)

OS: MacOS Mojave (v 10.14.6)

PsychoPy version: Psychopy3 v1010.12 (using Builder)

Standard standalone? Y

What are you trying to achieve:

I tried updating my psychopy experiment on Pavlovia with a new version of the experiment, but it will not sync. I don’t get an error when I try to do sync, but the sync dialogue box that used to pop up in builder simply will not. It appears as if the program just doesn’t respond after I click on sync.

What did you try to make it work?

  • Signing out and signing back into Pavlovia
  • Restarting my computer to get around any potential glitches with psychopy
  • Setting the study to inactive on Pavlovia, and then activating it again
  • deleting browser caches
  • Trying to run the study in incognito mode
  • Trying to run it in another browser (Safari - which makes it crash because it says that it’s missing audio files, which it isn’t)
  • Manually replacing the old files on the GitHub repository with the new files
  • Following the guidelines in the post linked step by step, which just created a new version of the study which I needed to get approved by my department admin. They approved it, but now that version is giving me a 403 Forbidden error so I can’t use that one either, even though it is virtually identical to the first version that does run. The only difference I’ve noticed is that it says “unknown” under platform type rather than PSYCHOJS
  • An added complication of having followed the guidelines of that post is that my experiment in builder is no longer associated with the original version of the experiment (which at least had been working). So I don’t know if I can even get my experiment in builder to sync with the pavlovia project that it was originally assigned to.

Post I followed:

Link to my study: SICR NAD [PsychoPy]

Link to the gitlab: Sign in · GitLab

Link to the new study that following the above post created (403 Forbidden error): https://run.pavlovia.org/esi6/nadsicr1

Link to that gitlab: Sign in · GitLab

Hi Eris,

This issue is likely related to the builder instead of the online features. Could you repost your question in the builder category? Then we’re sure the right people will pick it up.

Best, Thomas

Hi Thomas,

Thanks for your input - I have reposted the question in the builder category!