psychopy.org | Reference | Downloads | Github

Synchronising issues: variants of the same experiments in different folders

Ok so this one is a bit hard to describe:

I am building a sandbox environment to experiment with completion URL passing.
For my actual study I have 4 different studies that I need to present in a Latin square design.
But rather than messing up the existing experiments, I wanted to create 4 variants of an extremely simple thing and see whether I can get the completion URL dependant open expInfo[“Group”] to work.

So I created a simple experiment that just shows the letter A and then ends
I then saved the same experiment again in a separate folder under a different name, and changed the text it shows to B
You see where this is going -=-= I have versions A, B, C, D of this very simple thing.

Then I added the JS code to the A experiment and synched it to Pavlovia.
When I tried creating projects for B C & D, I ran into all sorts of problems.

I have been banging my head against this all day – with the repository on GitHub not having any entries, GitHub complaining about the local root, etc.

So here is what I currently have:

A folder structure where there are 4 folders (entitled A, B, C, D) inside a parent folder (called URL_redirect Sandbox).
Inside each of the respective folders lives the corresponding .psyexp file (e.g. A.psyexp, B.psyexp, etc).

I then have deleted all the local html folders, and also removed all the associated projects on Pavlocoa. I then created a new project for A
This seemed to have worked for A
But as soon as I try to move to B, it automatically lists it as A on Pavlovia.
I can create a new project on Pavlovia, but when I want to change the local root to the B folder, it complains that the folder is inside a folder and that GitHub does not allow that.

Where am I going wrong and what is the process to set this up?

If you create the new project by copying the local files, you need to delete the hidden .git folder.

If you fork the experiment on Pavlovia I think you have to fork it to a group and then back to yourself – I believe you can’t just fork it to another copy yourself.

In fact, I’m a bit unclear about the whole forking process – I’d hope that if you make a change in the original there’s an option to update the child but I’m not sure if that works.

1 Like

Thanks @wakecarter – deleting the hidden .git file did the trick!