Sync problem unsolved

URL of experiment:
Description of the problem:

Hi, everyone. I am quite new to psychopy and pavolovia, especially to python and java.
I encountered ‘403 forbidden nginx’ message when I tried to run pilot in pavolvia.
I read other postings but I couldn’t find a proper solution to me.

The weird point is that the online experiment worked well before a certain point.
At a certain point, the error message (403 forbidden) showed up, so I deleted the gitlab project, recreated one, then synced all the files in the folder.
I can see relevant files when I click ‘view code’ tab, but ‘pilot’ mode does not work.
I even rebooted computer and synced again, and I removed a routine that I added right before the error message and synced again.

Platform version was 2020.2 but it changed to 0.

Can anyone help me with this problem?
I posted both my link and the psyexp file.

Update in error:
I removed gitlab repository again and tried to make a new project.
However, when I clicked ‘ > New’ tab, error message showed up.

Traceback (most recent call last):
File “/Applications/”, line 146, in submitChanges
File “/Applications/”, line 330, in createProject
File “/Applications/”, line 486, in init
File “/Applications/”, line 543, in pavlovia
TypeError: argument of type ‘NoneType’ is not iterable

I found that the project was created, but failed to sync the files with error below.

Traceback (most recent call last):
File “/Applications/”, line 1233, in onPavloviaSync
AttributeError: ‘NoneType’ object has no attribute ‘save’

It is a long long way to run online experiment indeed…

ResponseCue.psyexp (99.9 KB)

Hi Hij113,

Sorry to hear it’s a challenge to run studies online. I have to admit that even with 15 years of experience in online research, I sometimes feel the same way. However, once it works, the speed and ease of data collection often makes up for it.

Your sync issue is a problem with the builder. Could you repost your issue in that category so that we’re sure the right people pick it up?

Best, Thomas

It looks like this is still in the “builder” category. I am having the same issue and have run around in circles trying to figure it out.

This is the error I receive when I attempt to Sync from builder to Web.

Traceback (most recent call last):
File “/Applications/”, line 161, in submitChanges
AttributeError: ‘NoneType’ object has no attribute ‘project’

The files do appear in a project on gitlab, but I am never able to run a pilot test. Sometimes attempting a pilot leads to a 403 error; sometimes it says “initializing experiment” but gets hung up forever.

I have tried this on two separate computers, and tried in several different versions of PsychoPy builder, because a different forum thread suggested using an earlier version as a workaround. None of these attempts resolved the issue.

Is this my error or a bug? If a bug, I am unclear how to “manually push” to gitlab from my computer (novice cover, here, sorry!).

Thank you for your guidance, I am happy to provide additional details if that would be helpful.

I am having the exact same issue, same line and same error. Did you resolve this problem? Thanks in advance!


I resolved this problem and it was quite simple.

The problem I had was that js version (platform version) was not read, because the files were in the wrong directory.
When you access your gitlab, all the relevant files should be in the ‘html’ folder. The first look should be ‘html’ folder and ‘.gitignore’ file (this file is automatically created).
I created the folder manually in the local computer before I sync the files into the gitlab, because it was not automatically created.
Inside the html folder includes all the relevant files including the resources folder.

I hope this comment solves your problem, too.
Happy experimenting :slight_smile: