psychopy.org | Reference | Downloads | Github

Stuck on “Initializing Experiment”

Hi all! I created a similarity judgement task (for American Sign Language) that runs just fine on PsychoPy. I followed the instructions to upload it to Pavlovia and I can see all of the files in the repository, but when I try to run/pilot it on Pavlovia, it gets stuck on “Initializing Experiment” and nothing happens. I checked the output from PsychoPy and everything looks alright to me:
“Pushing files to Pavlovia
Pushing to Pavlovia for the first time…
Branch ‘master’ set up to track remote branch ‘master’ from ‘https://oauth2:25c5fd52934be1aa0a278ba6d7ff27d26a42ecb3241597a549e68a3c7a78e464@gitlab.pavlovia.org/fcooley425/asl_rjt.git’.
Success!
Pulling changes from remote…
Already up to date.
done
Pushing changes from remote…
done
Successful sync at: 12:50:23, took 2.272s3224.1845 WARNING Project fcooley425/asl_rjt has changed gitlab ID since last use (was 106851 now 106873)
3226.4572 INFO Successful sync at: 12:50:23, took 2.272s”

Any thoughts? Here’s the link to the task: https://run.pavlovia.org/fcooley425/asl_rjt

Hi There,

I don’t think this is an issue with uploading (the sync looks to have been successful!) but rather, this seems to be a “stuck on initializing screen” error - would that sound accurate?

If so, please may I check if you have tried opening developer tools to reveal your error message? this will help pinpoint the problem. If unsure how to open developer tools the PsychoPy Python to Javascript crib sheet provides info on how to do this with different browsers.

Thanks!
Becca

In case helpful, there is also a link to a tutorial on how to debug these kind of errors here PsychoJS Coding and Debugging — PsychoPy v2021.1

You were completely correct, thank you so much! There were some syntax errors that I fixed, and the experiment now begins! Of course, however, I have a NEW problem! Even though the welcome screen and instructions display, I get the following error right before the first video stimuli should play:

I’ve double and triple checked all the path names and the movies play locally on my laptop as well as in the experiment in PsychoPy. Any thoughts? Thanks again for your help!

Perhaps I should have also included the link to the new experiment:
https://run.pavlovia.org/fcooley425/sign-rhyme

My stubbornness paid off!!! I figured out what was wrong.
For anyone having the same problem, I just converted my video files in mp4 with H.264 encoding and it worked.

1 Like

woo! pleased you found a solution and thankyou for sharing!

Hi there, I am trying to create a similar task (no pun intended), but with images instead of video files. Would you happen to still have the code for your task?

Psychopy resources for Similarity Judgement Tasks seem to be scarce, and I have been looking all day. Thanks!