Resources are not downloaded in the beginning

URL of experiment: Raimund Bühler / ralt_tewa_mew · GitLab

Description of the problem: I keep running into a “resource not found” error with my experiment. It seems not to download the resources in the beginning.

I tried to manually add all resources in the preferences → online tab and deleting the html output path, but the experiment still runs from the html folder. When deleting the html folder, it’s missing the lib folder to load psychojs, which is specified in the html file? I don’t know why it’s not creating an html file which loads psychojs from the server, but tries to locally find psychojs?

Any help would be greatly appreciated. It was running fine before, i think recreating the experiment from a different version of psychopy caused the error :frowning:


the brute-force way is

  1. to delete the local html-folder (not needed in recent PsychoPY-versions),

  2. delete the hidden .git-folder and .git-ignore file.

  3. delete the project on Pavlovia and

  4. resync to a new project.

You might have still to clear browser cache. I am not quite sure whether you really have to delete anything more than the .html-folder because I vaguely remember that this was sufficient for one of my experiments.

See also here

Best wishes Jens

I’ve found that deleting the entire project is no longer necessary. Most recently (earlier this week) I deleted the local html folder, removed html from Experiment Settings / Online and synced. I also set the project to inactive then active again for good measure.

The weird thing is, when i do that, it tries to locate psychojs from the lib folder which is not created at any point. I also tried to manually add it, but it’s not uploaded on sync, because it’s in the gitignore

Screenshot 2022-10-13 at 14.25.23
The html also looks for it in the lib folder, and does not try to download it? I also tried to replace the html file by an older file from another experiment that had the URL for psychojs in it, but it didn’t work…

ok, i did it your way and it worked :slight_smile: thanks for helping out!