Resources not downloaded at beginning

Screenshot 2022-09-19 at 16.12.11
URL of experiment: Raimund Bühler / Social_Context · GitLab

Description of the problem: When trying to pilot the experiment, the resource folder in the html folder is not automatically downloaded (i.e. no download bar at the bottom of the inital window). The first two text stimuli (instructions) are presented fine, but I run into an error when it tries to grab the first conditions file.

I have not encountered this error before and don’t really know what could cause it? Any help is very much appreciated!

Hi @RayBuehler, you can remove “html” from settings → online → output path and input all resources that your experiment will need under settings → online → additional resources. Then export the js again and sync with pavlovia. Also, I noticed that some of your xlsx files contain absolute paths of files on your pc. Make sure to use paths relative to your experiment folder so it also works online and finds the right resources.

cool, thanks for your help, I’ll check that out!

Hey, I followed your advice, however it apparently didn’t solve the problem. it looks like it won’t even download any resources when starting up the experiment (see screenshot). I also already created a new repository from the same experiment and it runs into the same problem… would you have any other ideas?
Screenshot 2022-09-20 at 10.01.20

Also, i get the following error in the console when starting up the experiment

seems like there’s no connection to the server?

When I download your experiment, recompile the js (because I run 2022.2.4), and start the experiment in local debug mode, I get this


What happens when you run the experiment local debug mode?

I’m running, 2022.2.2 and I always just hit the sync button to update the changes to pavlovia. How would I recompile the js?

Syncing also recompiles, if you just want to recompile you hit the yellow JS button on the top of the screen.

ok, no that didn’t change anything unfortunately. local debug mode doesn’t work for some reason I get the following error.
Screenshot 2022-09-20 at 10.18.31
I always “debugged” by first syncing with pavlovia and running from there, probably less effective

Does give you any error message in the console?

no, just a warning

should i delete the html folder? seems it now has all the files in the project root (including index.html)

Maybe update to the latest PsychoPy version so we know it’s not simply an error with that.

Yes, you may also delete that folder but I don’t think that it messes things up by just being there.

ok will update and check if error persists. thanks so much for helping out, get back to you soon :slight_smile:

i updated to 2022.2.4 and still the same problem when trying to run local :frowning: firewall is turned off also…

This is the experiment exactly like it is on my hard drive and it’s working. Could you download it and without changing try to run it in local debug?

same problem, same error. maybe because i’m running from mac?

Might be.

Could you also try uploading this project to pavlovia, but before you do set experiment settings → online → Export HTML to “manually”. This way your experiment won’t be re-compiled before the upload but exactly the files that are there right now will be uploaded.

Sign in · GitLab

Does it run? Can you make it public?

oh, it works actually!

sorry, thought i did. i don’t really get what solved it though. can you explain?

if not, i’m happy it works :slight_smile:

Ok, so the next step would be to turn Export HTML back to “on sync”, then sync and see if it still works.

No, not sure. Maybe just the update.