psychopy.org | Reference | Downloads | Github

Resources not downloading automatically all of a sudden (bug?)

URL of experiment: Pavlovia (previously working one), Pavlovia (previously working one), Pavlovia (one of the two new ones)

Description of the problem: Many of my Pavlovia experiments are all of a sudden not loading the resources automatically. The page opens and the dialogue box never says “resources downloaded” or “downloading”, so then it says my resources don’t exist when I hit ‘okay’ to run the experiment. Not only is this happening with two new experiments I’m currently trying to set up, but also with two existing experiments that have been running fine online for months without being edited at all. Just out of the blue. I piloted all of my experiments to see if there was a pattern and noticed it’s only happening with the experiments that are running on PsychoJS 2021.2.3. I’m trying not to touch the two existing experiments that have been running, but I tried manually entering the resources in Experiment settings → Online → resources and a code with the new experiments to try to get the resources downloaded, but neither of those worked. Is anyone else having this problem? Thanks!

Edit: When I manually changed the experiment to use PsychoPy version 2021.1.4 via the experiment options (even though I’m still editing using 2021.2.3), it downloaded the resources automatically again. I know you’re not supposed to do that and now it’s created other issues, but I had to test the theory. So it seems to just be PsychoJS v2021.2.3 that’s having this problem all of a sudden. Is this a bug?

I may be having a similar problem, upgraded to the latest version of Psychopy yesterday (v2021.2.3) to try and solve a different issue, and now when I try and pilot my experiment, it doesn’t do the usual thing of downloading the resources, and saying “all resources downloaded” before I start the experiment (see attached image). The resources are definitely in the resources folder, and this was an experiment that has previously worked fine. psychopy error

1 Like

I’m so glad I’m not the only one having this issue!

Are you still using the html folder? I recently had to recreate an experiment without it to deal with this.

Just deleted the html folder and still the same issue. I’ve also tried creating a new project and still the same issue, but a brand new very simple test experiment showing a picture very briefly did not have this issue, and the resources downloaded no problem

Thanks for responding!

So we no longer use an html folder? Do we also have the resources folder floating with the .js, .html, and .psyexp files? When I didn’t have an html folder, other issues happened and it wouldn’t run. This still doesn’t explain what happened to the experiment that had been working fine up until yesterday. I literally hadn’t touched it in months and I randomly had a participant email me yesterday to tell me they got an error because an image didn’t exist. And then I piloted it and saw that resources weren’t downloading at the beginning out of nowhere. Did they change something in a PsychoJS file or something? Should I just go back to using v2021.1.4? I’ve only been having these strange issues since upgrading.

A dedicated resources folder that automatically downloads isn’t a thing any more. You can put resources into a folder called resources, but that’s your choice and isn’t different from any other folder name.

I suspect that someone accidentally upgraded your experiment to the latest version (by syncing from a computer with a new version).

There are advantages with using 2021.2.3 onwards for new experiments, but for an old experiment you aren’t going to change you could just try to get it running as an old version.

So where do the resources go? And how does Pavlovia know to download them? Do I have to tell it the location? I am doing this with a new experiment (and also figuring out what happened with the old experiment).

If the resource is fixed or set in a spreadsheet then Pavlovia will know.

If the resource is set in code then you need to add it via Experiment Settings / Online

I ended up temporarily fixing the problem with the experiments with few resources by just having them loose in the main folder with the .psyexp, .js, and .html files and then adding them to resources in the experiment settings. So they don’t load when they’re in their own folder. This is fine for my experiments with two resources to download, but for my experiments that have 500+ images, I’d prefer them to have their own folder. But you can’t add folders to the resources in experiment settings, only files. So do you know if there’s a way around this or do I have to redo things so that all of the images are loose in the main folder mixed with everything else? Again, this is only a recent issue–everything in all folders have always downloaded automatically until two days ago, so I’m still confused about what actually happened.

You should be able to select all the files in a sub folder in Experiment Settings / Online.

However, you shouldn’t need to if PsychoPy can “see” that those resources will be needed.

I can’t comment on what happened two days ago, and I don’t know if there is a new bug or just a removal of a legacy method.

That’s the problem–it doesn’t seem to “see” inside sub-folders all of a sudden

Would you like to share an example experiment with me which uses sub folders for resources but has been recreated without an html folder? I’ll see if I can trace the issue.

It only downloads what’s in the one sub-folder now.

Sorry, but you haven’t given me access. Please could you add me as a developer and unprotect the master branch if you’d like me to see if I can fix the issue.

1 Like

Try this version

https://run.pavlovia.org/Wake/eabtimecourse_images

Where’s the code? What did you do to fix it?

I’ve just given you access.

I deleted the resources/html folder (which had a copy of everything), fixed a couple of incorrect paths and added all of the resources in the sub-folders.

Oh oops, I just copy and pasted the old folder over because I had already taken them out. I guess I only half paid attention to what I was copying. So I’m guessing the issue was mainly with the resources that I added to experiment settings? Thank you so much for your help (as always)!

URL: tTraceTest8 [PsychoPy]

How do you set the code resources into Experiment Settings / Online? What should I input there?