Resource manager component issue: resources should be either (a) a string or (b) an array of string or objects

URL of experiment: moralsense_AI [PsychoPy]

Description of the problem: I’m having an issue getting the resource manager component to run. This is just a dummy run of my actual experiment so I can focus on debugging, my actual experiment will have over 200 videos - hence the need for some kind of resource manager.
I had a look at other posts on the forum and have tried to debug it this way but to no avail.
I sometimes get an error which says “unknown resource”, and I check the capitalisation etc., of the file compared to how I reference it and this is all fine.
Currently I have this error:

I don’t entirely understand how this all works but I think that it seems to be downloading the resources at the beginning anyway, despite me having a resource manager component, and then it runs this error.
When this error is displayed, the console shows this:

So therefore, has an issue with commencing download of resources (though as I say, it appears to be doing this at the beginning anyway).
I’ve included images below which show how I’ve tried to set this up (again this is just a dummy version to try and get over this issue):

(apologies in advance for sending so much stuff! I wanted to make sure there’s as much info as possible!)
Thank you in advance!


Did you mange to resolve this issue? I’m having exactly the same issue.

Did you try to add a custom item to the resource list?

Which bit do you mean sorry?

So I managed to get it to work if I uncheck “Check All”. In my final experiment I have several resource manager components throughout which was why I had this checked, but it doesn’t seem to work with it.