Quick Question about Pavlovia Image Files not Working

URL of experiment: Pavlovia

Description of the problem: When I attempt to run an experiment, this error shows up:

Unfortunately we encountered the following error:

  • when setting the image of ImageStim: trialGrid
  • when getting the value of resource: grid.png
  • unknown resource

Try to run the experiment again. If the error persists, contact the experiment designer.

I understand that this issue has been discussed and solved before (Image resource error in Pavlovia (not a resources/forward slash issue)), but I actually had a question on how to solve it. I’m unsure on what is meant by “recreating the experiment with export to field set to blank”. I cannot seem to find the Experiments Setting/Online in order to fix this issue. Does anyone have any advice?

Hello

The output path field can be found under Edit experiment settings, aka rack-wheel, on the Online-tab

grafik

Best wishes Jens

1 Like

Hi! Thank you for showing me where the setting is! However, I am still receiving the same error after deleting the output path and syncing. I also recreated the experiment by changing the local folder to a new one and deleting the existing Pavlovia project and creating a new one upon syncing. I am not sure if this is what is meant by creating a “new local folder pushing to a new online repository” like wakeforest said in the previously linked thread, but I am willing to do anything suggested!

Hello,

well, there is seldom the need to move everything to a new folder. But you understood wakecarter correctly. He meant moving everything to a new folder and a new repository. Most of the time it is sufficient to delete the repository and the .git-files (which might be hidden depending your your OS-settings) and resync.

  1. Is the file grid.png in your repository?
  2. How do set the ImageStim trialGrid to grid.png?

Best wishes Jens

Hi Jens! This might be a really simple question, but I am unfamiliar with git. Where do I go about finding the git repository on my computer? I use a Mac (Ventura 13.0.1) and I know that it is hidden on Macs, but I have no idea how to go about finding it.

Edit: I’ve found this folder, but I don’t know if this is what I’m looking for

Hello @parthnn1

see here to learn more about git. It is not necessary to locate the git-folder on your Mac but rather to look in your online-repository on Pavlovia to see whether the file grid.png is stored online.

The git-folder just contains files git needs to sync properly.

Best wishes jens

Hi Jens,

I went to the online repository on gitlab.pavlovia.org and it looks like grid.png is there within the files online. Should I delete the repository from gitlab.pavlovia.org or from the experiments tab on Pavlovia itself?

What did you mean by this? If you are asking about how trialGrid is showing grid.png, here is a screenshot from PsychoPy of the trialGrid properties:

Edit: I used wakecarter’s error list on the crib sheet and added the grid.png to Experiment Settings>Online>Additional Resources and double checked that grid.png was also on the online git repository. I’m still getting the same error. Here is the screenshot of what I did:

Hello,

Well, is grid.png (typo corrected) in the same directory as a the experiment file in your repository?

I don‘t know why you want to delete anything. I suggest you read

to get a better understanding how PsychoPy and its online cousin PsychoJS work.

Best wishes Jens

Hi,
I’m not sure what you mean by Greg.png, sorry. The grid.png file is within the same directory as the experiment though. Here is a screenshot of the repository.
Uploading: Screenshot 2023-01-07 at 11.03.31 AM.png…

Sorry

Typo. I meant grid.png, auto-correction. The screenshot did not upload? I can’t see it. You might giving me access to your project by adding me as a developer?

Best wishes Jens

Sorry, the screenshot didn’t load properly. Let me try again:

It is in there, so I’m pretty unsure of what to do.

You have a html folder. Try deleting it locally, ensuring your output path is blank and then sync to delete the remote copy.

It worked! Thank you so much!!