psychopy.org | Reference | Downloads | Github

PsychoPy3 error (Mac HighSierra ver. 10.13.6)

Hi there,

I was trying to install PsychoPy3 and everything seemed ok, but when I start the app from the Application folder I get this warning message.


Where should I look to get more information about this problem?
Thank you for your kind attention and help.

1 Like

I have similar issue. After running it on mac, it freezes.

Was it possible to click on the Open Console button to get some error messages?

Have you got git installed? That’s the most obvious way I can see the app not starting (sorry - I didn’t get time to handle that simple config!)

https://git-scm.com/download/mac

Installed git, but I still get stuck with “beach ball of death”

Thank you for your replies. I’ve installed GIT on my Mac but I’m not sure if it’s properly configured because I haven’t done anything after the installation.

I get the same error as the OP.

Mac 10.13.6
StandalonePsychoPy3_PY3-3.0.0b2.dmg
git installed
With Anaconda install of Python 3.6.5

Also did a conda update --all to take me to Python 3.3.6 and that same crash happens.

Happy to paste in the massive Problem Report if that would be helpful?

Hi drbenvincent,

I won’t be able to read and understand the Problem Report, but maybe somebody else could help us here.

1 Like

I’m trying to connect with Pavlovia, I don’t know if that is the problem.

I gave up. Has someone had any luck trying to make PP3 work?

We’ve tracked down another issue that only occurs on some machines and I’ve uploaded a new beta (3.0.0b3). Maybe you could give this a go and see if that solves the problem?

If that doesn’t fix it for you then, yes, seeing the error messages might help (please post)!

Hi,
thank you so much for your work.
With the latest beta version, it only starts when launched via terminal. Otherwise, it just crashes without any warning message. Starting it via terminal, it crashes during the process of pushing/pulling.

This is the console’s output (hope it will help):
Console report.xlsx (57.5 KB)

I sincerely hope I’m not giving you a headache!!
Thank you very much.

Valerio

Same error for me I’m afraid. Builder window opens but the PsychoPy3 Error box (see first post) pops up.

This is such a mystery. I open both the Py3 version and the Py2.7 version on my macbook air with 10.13.6 and the only issue is the annoyance of being ‘not a known developer’.

The console log didn’t include anything useful. Maybe if you could open the console, reset it, and then try to launch PsychoPy so we only get the relevant messages. At the moment you seem to have a lot of messages about some advertising app, and I don’t think those could be related to PsychoPy or Python.

Presumably this isn’t related to problem in the original post, but I’d like to track it down too. If you get an error message could you send it (potentially a separate thread)?

Hi Jon,

thank you so much.
Sorry, it’s me, I was not able to single out the relevant parts of the console report. I hope I’ve done a better job now.
Console report.xlsx (30.3 KB)

I will post the crash report for the other issue on a sperate thread.
Thank you again.

Valerio

UPDATE:

I was able to make it work starting Py3 via terminal, but messed up with my Pavlovia account because of the various attempts. I deleted my Pavlovia account to make a fresh start, but now I get this from the terminal:

Last login: Tue Jul 31 19:50:12 on ttys000
MBPdiVaerioCori:~ utente$ /Applications/PsychoPy3.app/Contents/MacOS/PsychoPy3 ; exit;
Traceback (most recent call last):
File “/Applications/PsychoPy3.app/Contents/Resources/boot.py”, line 430, in
_run()
File “/Applications/PsychoPy3.app/Contents/Resources/boot.py”, line 409, in _run
exec(compile(source, path, ‘exec’), globals(), globals())
File “/Applications/PsychoPy3.app/Contents/Resources/psychopyApp.py”, line 96, in
start_app()
File “/Applications/PsychoPy3.app/Contents/Resources/psychopyApp.py”, line 28, in start_app
app = PsychoPyApp(0, showSplash=showSplash)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/_psychopyApp.py”, line 178, in init
self.onInit(testMode=testMode, **kwargs)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/_psychopyApp.py”, line 304, in onInit
self.showCoder(fileList=scripts)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/_psychopyApp.py”, line 495, in showCoder
files=fileList, app=self)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/coder/coder.py”, line 1426, in init
self.makeMenus()
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/coder/coder.py”, line 1870, in makeMenus
self.pavloviaMenu = psychopy.app.pavlovia_ui.menu.PavloviaMenu(parent=self)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/pavlovia_ui/menu.py”, line 48, in init
self.setUser(PavloviaMenu.appData[‘pavloviaUser’])
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/app/pavlovia_ui/menu.py”, line 91, in setUser
pavlovia.getCurrentSession().setToken(token)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/projects/pavlovia.py”, line 381, in setToken
self.startSession(token)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/psychopy/projects/pavlovia.py”, line 403, in startSession
self.gitlab.auth()
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/gitlab/init.py”, line 211, in auth
self._token_auth()
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/gitlab/init.py”, line 233, in _token_auth
self.user = self._objects.CurrentUserManager(self).get()
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/gitlab/exceptions.py”, line 251, in wrapped_f
return f(*args, **kwargs)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/gitlab/mixins.py”, line 67, in get
server_data = self.gitlab.http_get(self.path, **kwargs)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/gitlab/init.py”, line 728, in http_get
streamed=streamed, **kwargs)
File “/Applications/PsychoPy3.app/Contents/Resources/lib/python2.7/gitlab/init.py”, line 702, in http_request
response_body=result.content)
gitlab.exceptions.GitlabAuthenticationError: 401: 401 Unauthorized
2018-07-31 19:52:58.697 PsychoPy3[2696:97200] PsychoPy3 Error
logout
Saving session…
…copying shared history…
…saving history…truncating history files…
…completed.

How can I get a fresh start and go back to ground zero? Do I have to post this in another thread?
Thanks.
Valerio

Probably this has PsychoPy knowing the key for the user but the user no longer existing in the server (I never tested that possibility).
In terminal you could run

rm -R ~/.psychopy3/pavlovia

And the stored info about previous projects and users will be gone

2 Likes

But we (probably @dvbridges) will of course also fix this in the app so that if the logged in user has been deleted on the server it won’t crash the app! :slight_smile:

Thanks for your patience as we work through these teething issues.

Jon

Thanks Jon, that was helpful. Now I am able to start Py3 via terminal.
I still can’t make my experiment work online, though. When I press “run” I get a blank page on the browser. I cannot figure out what’s wrong.
There is another thing that I’ve noticed: there is a project that I am trying to remove from Pavlovia, but after a while it keep coming back to life. This causes the problem that if I want to sync the same local folder to a new project, I get an error (fatal: remote origin already exists). And I get this from the terminal:

objc[9360]: Class FIFinderSyncExtensionHost is implemented in both /System/Library/PrivateFrameworks/FinderKit.framework/Versions/A/FinderKit (0x7fffa9230c90) and /System/Library/PrivateFrameworks/FileProvider.framework/OverrideBundles/FinderSyncCollaborationFileProviderOverride.bundle/Contents/MacOS/FinderSyncCollaborationFileProviderOverride (0x124e87cd8). One of the two will be used. Which one is undefined.

Thank you again for your work!

And I forgot to mention that the output that comes up from the coder while I get the blank page on the browser is this:

PsychoJS doesn’t support win.callOnFlip() for keyboard
PsychoJS doesn’t support win.callOnFlip() for keyboard
PsychoJS doesn’t support win.callOnFlip() for keyboard
PsychoJS doesn’t support win.callOnFlip() for keyboard
PsychoJS doesn’t support win.callOnFlip() for keyboard
PsychoJS doesn’t support win.callOnFlip() for keyboard
PsychoJS doesn’t support win.callOnFlip() for keyboard

I hope it’s helpful.