psychopy.org | Reference | Downloads | Github

Psychopy won't open after fresh install on windows 7 pc

Hi all,

I’ve just installed psychopy on a new Windows PC (Windows 7 SP1 64 bit, on a Dell OptiPlex 9020) for testing in our lab, but encountered some problems. After installing, if I try to open psychopy nothing happens. It doesn’t open at all, nothing comes up, and no process is visible in task manager for it either.

I ran "C:\Program Files\PsychoPy3\python.exe" -m psychopy.app.psychopyApp in cmd as per the troubleshooting page, and it spits out some errors. It tracks down at its base to:

File "C:\Program Files\PsychoPy3\lib\ctypes\__init__.py", line 348, in __init__
    self._handle = _dlopen(self._name, mode)
OSError: [WinError 126] The specified module could not be found

along with some other errors that are above it (see attached picture)

This is really weird, and happens when i try to install either PsychoPY3.2020.1.1 or 1.2 for win64, both give me the same error. Any ideas on how this might be fixable (if at all?)

Thanks!
Sammi!

This bug should be fixed in the latest release. The issue is related to HighDPI support being broken on Windows <8.1. Get it here and try it out: https://github.com/psychopy/psychopy/releases

1 Like

I’ll give this a shot and see what happens. thanks!

this worked, thanks a lot!