psychopy.org | Reference | Downloads | Github

Problems with synchronizing on Pavlovia (Earlier version of experiment opens up)

I have been having problems with uploading the most recent version of my experiment to Pavlovia.
For some reason the experiment that opens in my browser (Chrome or Safari) is a version that I made earlier (about a week ago on 25-06). It is a version for which I deleted the Github project, but that somehow remains on my ‘Dashboard’ in Pavlovia.
I also find earlier data files from earlier versions in the repository of my most recent project.

Should I bear anything in mind on Github with regard to merge settings to solve this?

1 Like

Hi @tjl, can you please share the URL for your task that does not appear to update?

Dear David,

Thank you for your reply.
Are you able to access these URLs? Please let me know if I need to change any settings if the content is not displayed for you.

This is the pavlovia site for the experiment I uploaded yesterday:

But when I run the experiment, an old version of the experiment (PP_BPON_25-06-2019) shows up:
https://run.pavlovia.org/timlameris/02-07-1821/html/?__pilotToken=c041bf164f7a2adcd202f1289f024162&__oauthToken=737aed4c8dd6b9d6f48eb6a2e845a064ab251287373a0332afa6abbded85c6f4

The gitlab site for the updated experiment (02-07-1821) is here but contains some earlier (data) files from earlier versions of my experiment (including PP_BPON_25-06-2019), I wonder if this has anything to do with it:

@tjl, there seems to be multiple versions of the experiment saved in your html folder, and your new version that you want to run is saved in a “html(1)” folder. This is why your old version is running, because PsychoJS will look in your html folder for your experiment files. What I suggest you do, is sync your study to make sure all is up to date, then go into your local experiment folder, and delete both html folders, and resync. This will create your new html folder with the new files, and should then upload them to Pavlovia.

Dear David, thank you for this tip. I tried this but am unfortunately still experiencing problems with an older version popping up instead. I do get the updated html files in my local experiment folders. Can I run these in any alternative way rather than uploading them through the PsychoPy application?

Otherwise I think I’ll have to rebuild my experiment from scratch, as I just tried running a simple ‘Hello World’ experiment on Pavlovia, which worked fine (so there doesn’t seem to be a problem with synching and running online in general). Perhaps something is broken in the original code or settings of my experiment that causes an older version to pop up.

@tjl, I am still seeing the html folder in your repository with the old versions. Are you deleting the folder on your computer locally? It looks like you have created a new repository but this has not been filled. So, try the following.

  • Close PsychoPy
  • Delete your unwanted repositories from Pavlovia
  • Clear your cache on your browser, just to make sure
  • Go to the experiment folder on your computer, and delete the .git folder - .git folders are hidden, so you have to make sure you can see hidden folders in your folder options in Windows Explorer. Also delete the blank text file (its your .gitignore file)
  • Delete all html folders

Now, when you open PsychoPy, open the task again and create a new project on Pavlovia.

1 Like

@dvbridges Thank you ever so much! That seems to have solved it.