psychopy.org | Reference | Downloads | Github

Problems with running the study online from the Builder

So I am logged into my Pavlovia Account, the project has been created on the website and I have synchronised the latest adjustments, BUT the study won’t run online from the builder.

The “synchronising” window is open but nothing happens.

Another issue/thing I don’t understand:
So I synchronised my project from the builder and it is updated to the newest version on GitLab.
But when I pilot the study straight from the Pavlovia website, it runs the “old” version.
I have tried going back to inactive and then pilot it again, but still the “old” version.

Looking forward to any advise and help :slight_smile:

thanks

Same, I’m afraid I just don’t understand how to interface between gitlab and pavlovia. Curious to know how you resolve.

@M_Badwal, what version of PsychoPy are you using? Also, if your browser is not running the most up to date version of your task after syncing successfully, then try refreshing your browser cache.

@dvbridges I am using PsychoPy3, version 2020.1.2

I will try deleting my cache and then attempting to run it again.
This wouldn’t explain to me why the project won’t run from the builder in my browser though I suppose.

Yesterday it worked just fine.

@M_Badwal, the project will only run from Builder if you have set the project status to “RUNNING” on Pavlovia - then you can run the task from Builder, but you will consume credits. The pilot mode on Pavlovia provides a unique time limited token in the URL, and this is not available to Builder, so piloting must be done from Pavlovia by clicking the pilot button. Does that help?

@dvbridges awesome, yes that absolutely helps and makes sense. I was hoping/thinking that I could also run it from the Builder in “piloting mode”.

Thanks a bunch.

You should be able to pilot locally via the runner as well as from Pavlovia.

If you have any import commands it will fail.

I’m working on a crib sheet here:

Best wishes,

Wakefield

Fantastic, thanks @wakecarter.