Pavlovia still not recognizing correct answers despite getting rid of .thisN attribute

URL of experiment: zzhuoran / ADD_Symmetry_Span · GitLab

Description of the problem:
Hi all, I know I’ve probably posted about the issues that I’ve experienced with my experiment running on Pavlovia several times now. However, I’m really hoping someone could assist me with this as I’m just down to one last issue that needs to be addressed. Long story short- I got rid of the attribute .thisN after finding out that it doesn’t work in Pavlovia. I was able to implement the incrementing variable into the builder today and it worked normally when I ran the experiment in psychopy (i.e., the experiment was recognizing the correct answer). However, when I ran the experiment in Pavlovia, it still didn’t recognize the correct answers. Instead, every answer that it recorded was marked wrong. Here are two screenshots of the new codes that I implemented into my experiment:

In short, what I’m trying to get to work here on Pavlovia is that after the participant sees a square appearing 5 times at any of the sixteen possible positions on the grid, they are asked to recall the order and the positions that the square appeared in.

Why are you starting trialCount at -1 in Python and 0 in JavaScript?

@wakecarter I did set trialCount at -1 in Javascript before changing it to 0. When trialCount was set at -1 in Javascript, Pavlovia marked all the answers as wrong. I changed it to 0 thinking that might be a possible solution. However, that didn’t work as well- Pavlovia is still marking all of my answers as incorrect. I double-checked the increment for Javascript in the end routine and it appears to be correct. Therefore, I really can’t figure out what else could be going on with my codes at this point.

If your problem boils down to this: " it still didn’t recognize the correct answers. Instead, every answer that it recorded was marked wrong", then that sounds like the same problem I ran into when rewriting an experiment in the new 2021 version: Correct response variable not recognised for new experiment with new version: 'key_resp.corr' always FALSE - #15 by TParsons.

The problem seems to have been corrected-just undocumented as a correction–in the latest version (2021.1.2). It took me some wrangling to get this new 2021 version to recognise the experiment I wrote in the first 2021 version (i.e., to update the “last run” python file), but it you play around with the version settings, you can eventually get it working. How, I can’t say, but if you mix it up and experiment enough, it’ll work.