psychopy.org | Reference | Downloads | Github

Pavlovia dashboard not showing projects that are on GitLab

Hello,

I’m having the same problem as this post, and it has similarities to this post and this post.

When I create and sync a new project to pavlovia, I’m recieving the ‘success’ message. But while the project appears in my GitLab repository it isn’t appearing on my dashboard. I currently have 3 projects that this is happening for.

This has happened in the past, and as others have noted, deleting the project from gitlab and re-creating the project usually does the trick (after deleting the .git folder, .gitignore file and html folder from the local directory). But this time that’s not working.

The gitlab repos affected are:
AnthonyGabay/rft_v1_instructions
AnthonyGabay/rft_v1_c

There’s another one which is currently deleted.

Some speedy help would be much appreciated.

Best wishes,
Anthony

Hello @Anthony,

Might I ask you whether you have already tried to solve the issue on your end?
As far as I can ascertain, both projects are certainly available from the dashboard. I even changed the status of rft_v1_instructions to PILOTING and could launch it (there is an issue with the experiment code but that is a different matter).
It appears that everything is working. Would you mind checking again?

Alain

Hi @apitiot,

Thanks for responding. The project does now appear to be on the dashboard. I did try removing the project and re-syncing again earlier, so perhaps this time it worked but there was a delay?

Either way, problem solved.

Thanks,
Anthony

I am glad that the issue has gone away.
I’ll dig through the logs to try and find the root cause, all the same.
Best of luck with your experiment and do not hesitate to contact us should you experience other issues: we are here to help :slight_smile:

Alain