| Reference | Downloads | Github

Projects not showing on pavlovia for *some* users of a group

I’m having an issue that is similar to this and the others that they link to there, but slightly different in that it’s specific to projects under a group.

Description of the problem: my lab has created a group within gitlab where we can jointly work on projects (we are all owners of this group). We have tested each of us making projects under our shared group in gitlab and have found that only some of us are able to see some of the projects in pavlovia. As far as I can tell, there doesn’t seem to be a rhyme or reason to which projects show and for whom they show. One project that a group member made might show for me while another made by that same member does not.

This is a list of our projects under our group named “PENS2”:

And my pavlovia dashboard:

As you can see for example, the project named “rivalry” is not showing in my pavlovia dashboard, although it is showing in gitlab (and is showing in pavlovia for about half of the group members).

We have managed to get our own projects to show for ourselves in pavlovia but still cannot figure out this issue between members within a group.


Did you find the reason for some group members not seeing the projects?
I’m having the same issue here and can’t find out why…

Thanks in advance!

I’m afraid I never did figure it out or get an answer. Please let me know if you happen to make any progress on it!

Hi @jbreedlo,

I solved it doing as follows:

  • Deleted the project on Gitlab (using the Pavlovia Dashboard)
  • Deleted the .git folder, and the files .gitignore, .html, .js and from my local files (i.e. the ones in my notebook)
  • Recreated the project on my Gitlab account by syncing it from Builder
  • Forked the project to my group

Part of it I saw in this post.

I’m not sure if that’s the best solution, but it worked for me :slightly_smiling_face:

I hope this can help you also.