Pavlovia can't download resource?

I finally got my experiment working in pilot mode and asked my student to do a full test-run (with the experiment status set to Running). She reported the following error, which is bizarre because the file named is definitely on the gitlab page (and yes, in the html/resources directory). But I’m also confused by what the “(4)” after the filename means - does that mean it tried to download it four times? I can’t find any experimental materials that refer to the file as having that suffix.

Any ideas what might be causing this, and/or how to fix it? Cheers,


Unfortunately we encountered the following error:

when downloading the resources for experiment: tonal-metric_tapping_V5
unable to download resource: tmCorrHigh_645_mod_new octave_108bpm.wav (4)

Try to run the experiment again. If the error persists, contact the experiment designer.

1 Like

Any update on this? I’m having the same issue.

With the current version you probably don’t have a resources folder. The (4) does mean it tried 4 times which would give an error. You can only download each resource once. I think also there was an issue here with not specifying the path but if possible you should now download resources via the online tab of the experiment settings.

I’ve made sure to export the html folder and it had a resource folder with everything in it, even the files that pavlovia said couldn’t be loaded. Any other reasons this error could have occurred?

Here is the experiment link if it helps: ReverbTest_RvF_key_soundlength_nestblocks [PsychoPy]