psychopy.org | Reference | Downloads | Github

Online study - "unable to save data to file"

URL: IDED [PsychoPy]

I’m currently trying to run an experiment but I have participants who have sent me this error below.

The output file is then just an empty CSV.

Any help is appreciated,

Hello @CDawes,

We temporarily ran out of space on one of the devices. The situation has been rectified and you should be able to save your data.
My apologies for the mishap!

Alain

It sorted it straight away - thanks Alain!

Hi @apitiot,

I got this error message again, today. Is this problem continues to happen? If so, I am thinking of pausing data collection, since I got several different error message from the server.

Thank you.

Good morning @Omidrezaa,

We are monitoring the situation closely. The issue is that a handful of users are being rather voracious with space at the moment. But you should be able to run your experiment without problem.

Alain

1 Like

Hi again @apitiot ,

Is this related to the server errors? I’ve had two participants send me these screenshot, both on Macs (sorry for the quality).

error

Best,

Chris

Hi.

I’ve just had the same problem…

Have I done anything wrong or is it the same issue as above?

Thanks!

Darren

Darren, yes, unfortunately yours looks like the space issue again - we’re battling with it at the moment I’m afraid as there have been a lot of large movies uploaded to the site in the last few weeks and we’re needing to upgrade our disk space to deal with those.

The undefined error looks different although I suppose it could be that it’s the same issue just portraying itself differently on a mac browser though.

@jon, some of my participants reported that they got “initializing the experiment” error after they finished the experiment. Is this also due to the storage issue?

I encountered the same problems too! One of the participants report "unable to save data to file error! 螢幕截圖 2020-03-14 23.42.50|690x431

and one reported the "initializing the experiment when he opened the link.

Please advise if these errors would exist? And should I continue to collect data? But the links were already sent out to participants…

Thanks a lot.

Heidi

The participants kept reporting the error, I stop my data collection now.

I think I am having isssues related to the same thing. I was unable to sync with my online git directory for one project that I am currently debugging. I keep deleting my project and restarting but that doesnt work as well. So I tried creating another project with another account. However, this was not possible since and it gave me ‘Failed to create repository via gitlab-shell’,‘Failed to create repository’ errors. When I move from piloting to running or back, it tells me ‘unable to pull project from GitLab repository: Cmd(‘git’) failed due to: exit code(1) cmdline: git pull -v origin stderr: ‘error: file write error (No space left on device) fatal: unable to write sha1 file fatal: unpack-objects failed’

That probably is related. Sorry about this folks. I’ve just freed up over 15Gb space so you should be good to go again, and we’re working to have the new much larger server online in the next few days.

So sorry about this impacting your studies

best wishes,
Jon

Thank you so much! It works perfectly now.

Thank you so much @jon. I hope it will be fixed soon.

Just a question. I still have the same issue with piloting and I am facing the same error at the end of piloting. Is that the same problem?

@jon Thank you very much for fixing the problem!
We have lost 3 credits due to the space problem, is it possible to waive?

Heidi

Yes, we can recreate those lost credits @ylchan . I’ll let @apitiot know.

@Omidrezaa I think the initialising issue must be something different. I’ve checked this morning and there’s still plenty of space for studies to run

1 Like

@jon thank you! We really appreciate your efforts in solving the problems.

1 Like

Hi @jon, the server seems running out of space again, could you please check? thank you very much!

Heidi