psychopy.org | Reference | Downloads | Github

Problem saving data and link not working in different computers

URL of experiment: https://pavlovia.org/catisf/sem_mem_ses2

Description of the problem: I am currently having two problems with my experiment on pavlovia and was wondering if anyone has an idea on how to solve them.

First, the experiment runs fine all the way through, but at the end of it I get an error saying it’s unable to upload participants’ results, without giving a specific reason for that (see image below). It had, in a previous version, stored data perfectly well but that has now stopped working. It shouldn’t be a size issue, since this experiment has only 27 trials (and I’m only saving key pressed and rt). In fact, when it worked, the experiment had twice as many trials! Any idea what the problem could be?

photo_2020-04-01_13-24-06

Secondly, while the experiment runs all the way through on my work PC, when I try it on my laptop (using the same browser - google chrome) it freezes on the “initialising the experiment” screen. The same happens if I try to open the link on my phone, for instance. Any idea why it works on some computers but not others?

Thank you for your help,
Catarina

Getting the same here with data saving. We are just waiting to get some credits set up, but making the experiment “Active” and then piloting gives the same message with a red bar on the box.

Slightly concerning, as we are hoping to shortly launch our survey to participants and don’t want any credits wasted.

Any chance you managed to solve it? I’ve tried a few different things, but nothing has worked so far!

I haven’t i’m afraid. What I noticed is that a script I had in pilot mode, when piloted would download the data files directly. I then had the same error as you when it was in a “Live” state, and then piloted.

We’re waiting to get some credits assigned, so we can see if we get the same results. If we do, then it seems to be an issue on PsychoPy/Pavlovia’s end that needs to be addressed.

One thing I haven’t tried is seeing if its anything to do with the “data” folder being missing on Github. I will try that now.

EDIT - Made no difference. I think someone from PsychoPy will need to take a look i’m afraid. The error message generated doesn’t give any indication of anything wrong with the data being saved. Just seems it cannot communicate with the git repository, but then for me that could just be because we don’t have any credits assigned yet.

Hello @catisf,

I just had a look at your experiment. It appears that you are trying to get your condition file from a directory called ‘Sub’ but your file actually is in a directory called ‘Sub1’, and so PsychoJS complains.
Would you like to change that bit and let me know how you get on?
Cheers,

Alain

Hello @fgasking,

We recently came across this specific use case and the associated issue. There is nothing wrong on your end, the error is ours. I will attend to it tomorrow morning and you will be able to pilot your experiment whilst running it by noon at the latest.
My apologies for the mishap.
Best wishes,

Alain

No worries, thanks Alain - really appreciated.

Sounds like it should just work for us once the credits are added as well, which is good to know.

@apitiot I have a similar problem with data saving but a different error message (413 Request Entity Too Large), is this a related issue? Before the maintenance last weekend, the data of this experiment were saved.

Hi @apitiot,

Thank you for getting back to me!

To get to the condition file, I added a code component on the builder in JS with the following code:

condFile = ((“Sub”)+(expInfo[“participant”])+("/materialTest.xlsx"))

At the beginning of the experiment, a box is supposed to show where participants write a number that I’ve assigned them. That should get coded as expInfo[‘participant’], so I thought by adding that to Sub, I was directing pavlovia to the right path. But maybe there is something wrong with my JS line? (I don’t normally code in JS…)

What puzzles me is that it had worked before, and I did not change that line! Plus, it still runs both when I run it locally and when I run it on Pavlovia from my work PC, provided I run it on my normal browser (chrome). If I run it on a different browser, or a different computer, from pavlovia, then it gets frozen on the “initialising the experiment” screen. This makes me think there’s some cached data that is allowing it to run on chrome on my work PC?!

Cheers,
Cati

Yes, I see! Sorry I had missed that in my haste to get back to you.
I have just tried your experiment on my end, and it is working like a charm.
Would you like to clear your cache and give it a go?

Alain