psychopy.org | Reference | Downloads | Github

Error with data saving

URL of experiment: https://pavlovia.org/Rianne/edo_mt1

Since this Monday, data are not saved anymore after running the experiment. The error message is: 413 Request Entity Too Large.

I piloted the experiment several times before the maintenance last weekend and each time I got a data file. This Monday, I did a final check before distributing it and it still worked fine. But since I changed the state of the experiment from Pilot to Run, I get this error message, even if I pilot it instead of running, and the data are not saved.

Is there a problem in the code of my experiment, or does it have anything to do with the updates of Pavlovia last weekend?

Hello @PsyLing,

I have just tried to run your experiment on my end. All I could see was a black dot, nothing else happened. You mention that your experiment worked for you when you piloted it. On which browser and operating system are you?

I pressed ESC, the experiment closed without issue. And I can see that a .csv and a .log file appeared in your /data subdirectory. So I do not believe that there is a problem with saving.

Alain

I use Google Chrome. Tu run the experiment, you should click on the black dot. In the next trial, you should click on any two pictures (I’m sorry, the instructions are in another survey).

It worked when I piloted it in the Pilot mode, but since it has been in the Run mode, it doesn’t work anymore (it still doesn’t if I pilot it right now)

The issue seems to be linked to the size of the results that the experiment is sending to the server, at the end.
Could you run your experiment in PILOTING mode and share the .csv result file with me so I have a look? It would have to be very, very large to get such an error, but it is entirely possible of course.

Alain

PARTICIPANT_EDO_MT2_2020-03-31_10h11.22.667.csv (1009.1 KB) This is a result file (it is of 31 March, but the experiment is still exactly the same). It is a mousetracking experiment, so it does increase in size depending on the time it takes to do the experiment.

This is just above 1MB, which is a typical limit for upload. It surprises me that this should be an issue however since I have configured the pavlovia server to accept all upload sizes. I wonder whether the company hosting our server has implemented restrictions related to the increased online traffic due to COVID-19.
I’ll contact them now. With any luck, I should have a fix for you by Monday.

Alain

OK, thanks a lot for your help!

https://run.pavlovia.org/Cami94/iatbrandbias/html/?participant=PARTICIPANT&session=001


Hi I also have the same problem,
eveything worked fine las week, and today we got the 413 error message

would it be possible to please get info regarding this ASAP? we are scheduled to go out with the test publicly in 3 hours…

@apitiot if necessary, can one remove all previous data? it is just consisting of tests and pilots

Thank you in advance

Hello,

As per my previous message, this is most probably an issue with the server provider. I wrote to them and am waiting for an answer. It would be better to postpone your public release until tomorrow.
I’ll let you know as soon as I do myself, of course.

Alain

Good afternoon,

I believe that the limit has been removed. Would you like to give it a go?
Best wishes,

Alain

I just ran it, but unfortunately it still gives the same error.

Would you try again? I made another change.

It works! Thank you very much!

I am very glad! My apologies for the mishap.

Alain

1 Like

Hello,

I was wondering if you are able to help. I am getting this error message at the end of my experiment!

Do you have slashes in the participant field? (/07/05/)

If so, that could be the problem.