psychopy.org | Reference | Downloads | Github

Online experiments on Pavlovia can not run in some web browsers

Hello,everyone! I had a problem when running online studies. It run successfully when I use Chrome and Firefox.
However,when I use IE browser or safari to run the same experiment, It cannot open, just like the picture below. Do you know how to solve this problem?

Safari we knew about - fix coming in the next few days. For IE which version are you using so we can test?

IE11,I tried to change the setting of the browser, but it still doesn’t work

No I think the issue is that all browsers have slightly different JavaScript interpreters and what works fine in one does not in another. Having the browser pretend to be a different client (I think that’s what you mean?) won’t help. We need to fix/test in IE11

Looking forward to the update

Is there any progress in testing IE browser ? I found that after the release of psychopy3 b0.04, the home page of pavlovia cannot be opened in IE11(before the version b0.04,only the experiment page cannot be opened)

Safari should be working (although it looked to me like mouse/touch events weren’t detected so we’ll need to look into that).

IE11 turns out to be a complete mess. We’re working to support it (probably in 3.0.0b7 sometime next week?) but, when we do, I would very strongly recommend that you use a better browser! Performance under IE11 will definitely be worse than almost any other option.

Firefox or Chrome are very much superior and work everywhere.

chrome and firefox are definitely better choices, but there are some participants who did not installed chrome or firefox in china. Since IE is the default browser for windows, it is installed in every computer, so it will be much better if IE could work, just to make sure that every participant can run the experiments, thanks a lot for your hard work!

There seems to be a browser glitch that comes up with safari sometimes in their macOS Big Sur version 11.2.3. We were able to get one run to go through but it glitched a lot. When we tried again it froze “experiment initializing.” I understand that could be a code related issue, however the experiment has ran successfully now in another browser multiple times without making any changes with the underlying code. This makes me think it is a browser related issue. (Safari is version 14.0.3)

Any advice is appreciated.

Have you looked at the Browser Console for an error message?

Safari > Preferences, click Advanced, then select “Show Develop menu in menu bar.”

Following up on @wakecarter, here is a tutorial on the console: Thomas Pronk / tutorial_js_semantic_error · GitLab

Hi All - I am pasting the error message we got.

I don’t think that’s a browser-specific issue. The browser says it can’t find your generated JS. What I find strange is how the URL looks. URLs to experiments have this structure:
https://run.pavlovia.org/<username>/<projectname>/<JS file>.js
But yours looks like this
https://run.pavlovia.org/mpipoly/Hierarch_Task_Alt_Full.js
Strangely, the projectname is missing.

What URL do you use to start the experiment? (please copy-paste it instead of using pictures, is easier for me to work with)

Hi - I did not see the reply until right now. This happens when I test the task in pilot mode (no tokens) through my account. I do not believe the URL that starts up generates a long-lasting link for you to try the task. Unless there is another way to share an active link with you, what else can I do to help provide you with the right information?

No worries; even a URL that doesn’t start the task can help me out

I do want to make note: The error will ocurr when I attempt to use the pilot tab link in the same window multiple times (the link on this web page: Pavlovia). Using a fresh window in Safari, it usually runs fine with the first launch. However, it will not with subsequent launches. Separately it has also glitched (during successful launches) but I have not been successful in replicating it on my machine well. Others in my lab who I have shared the task with have complained of similar glitches where there is weird lag. This is in Safari specifically. None of these issues have happened in Chrome or Firefox. I am not sure if this is related to the same issue or something else but wanted to share this extra information.

Task ran in this window.
https://run.pavlovia.org/mpipoly/triad-control/?__pilotToken=37693cfc748049e45d87b8c7d8b9aacd&__oauthToken=21355b15b787af81332b5f56a981c32ecd34ca9df4711b4beccc54ac2c1b8a73

error on this window
https://run.pavlovia.org/mpipoly/triad-control?__pilotToken=37693cfc748049e45d87b8c7d8b9aacd&__oauthToken=21355b15b787af81332b5f56a981c32ecd34ca9df4711b4beccc54ac2c1b8a73

Heya. I clicked the link but I got a 404 error. Guess you set the experiment on inactive?

No, the experiment is still in pilot mode in my account. We have made some tweaks to it so possibly those changes have affected the link? Overall, we have chosen to encourage folks not to use safari in order to avoid whatever is causing this to happen to some folks, and not others.

I am very grateful for any help and insight. Let me know if there is something else I can do.

Link to Safari on my computer when issue arrises, https://run.pavlovia.org/mpipoly/triad_control?__pilotToken=c4ca4238a0b923820dcc509a6f75849b&__oauthToken=21355b15b787af81332b5f56a981c32ecd34ca9df4711b4beccc54ac2c1b8a73

I took a peek and saw the experiment runs on 2020.2. A good first step could be upgrading it to the newest version of PsychoPy (2021.1.2)