psychopy.org | Reference | Downloads | Github

Task crashing on Internet Explorer and Safari

URL of experiment: https://pavlovia.org/Amber_Copeland/vbdm_task

Description of the problem:
We initially piloted the experiment (less optimized version than it is now.) on pavlovia and it crashed for ~70% of participants although it worked on a couple of our own computers on chrome. Our problem was similar to this post here. We reduced the number of routines as suggested above, and then tested it on multiple computers and browsers this time.

The task works well on Chrome, Microsoft Edge, and Firefox browsers. However, it does not load on internet explorer 3 out of the 3 computers we tried. And it did not work on safari 2 out of the 3 computers we tried. In one case, it did not recognize the mouse during dragging and dropping, and in another case, black boxes replaced the text components about half way through the task

Are there any issues inherent within our task that we could fix (or further optimize) to get it working on these browsers or are these browsers generally not supported by pavlovia? Thank you.

It’s hard to tell from this what the issue is within your study. One immediate tip is to try upgrading to the latest version of PsychoPy (2020.2) and re-export your study so it uses the latest bug fixes. We’ve been making improvements constantly including several compatibility fixes.

Internet Explorer is something we try to support but it’s difficult because it doesn’t support a lot of modern browser features. It does represent just about 1% of users though so it also isn’t a priority case. https://gs.statcounter.com/browser-market-share#monthly-202010-202010-bar

Safari is something we work harder on because it’s popular, but it is also hard because Apple are a law unto themselves and don’t stick to any industry standards. Again though, this is the sort of thing that we’ve worked on a fair amount in the last few months and you might well find that upgrading is enough to make your study work.

If not then one tip is that a number of issues people have had came from the use of dynamic stimuli (updating on every frame). Looking at your code I see just one of those as far as I can tell, so that might not be your issue, but text_1 is set to update every frame when it could just be Set Each Repeat as far as I can tell.

Beyond that if you could be a bit more specific than “it did not work” that would make your question more answerable. What were the symptoms of “did not work” (went black, crashed, didn’t respond…)? Was it at the start or halfway through? Always the same place? Was the problem the same in each machine that failed or did symptoms differ? Could you narrow it down any further? Did it work up until the point that you added feature X? These are the specifics that will get your question answered better :slight_smile: