No app in the folder, can't open .psyexp files directly

Hello everyone,
I’ve just installed Psychopy on a new computer. I can see the programme in the Program Files folder and there’s a shortcut in the start menu, which works fine. However I can’t my existing experiments by clicking on them. I’ve tried “open with” with multiple things, including the pythonw.exe, but nothing works. There’s also no other way to open the program other than the shortcut that magically appeared in the start menu, i.e. from the Program Files folder there’s no app that can be opened. Any idea how I can create a shortcut or something with which I can open my experiment files?
I’ve seen a previous topic that suggested creating a shortcut from psychopyApp.py but that didn’t work either.
Thanks for your help.

Hi @lcrible,

I just solved a problem that might be similar to yours. In my case I had selected a text editor as the default app to open psyexp files with. After that I couldn’t revert it back to PsychoPy anymore. This is how I managed to fix it. WARNING: the steps below involve editing the Windows Registry. Be careful when doing that.

  1. This guide was my starting point.
  2. In the folders I saw in my left panel, I deleted the one named .psyexp
  3. Next I rebooted my PC

I could then open psyexp files with PsychoPy (again).

Hope this helps!

Hi @thomas_pronk,
Thanks for your reply! Hmm I don’t if I can or should alter my work computer that way… Also, my problem is not with the “Open with” feature, but more with the fact that I don’t know which app to open my files with, as none of the existing apps in the Psychopy folder seems to work. So actually it is pythonw.exe that is set as the default app to open psyexp files, but they just never open.
It’s fine though, as long as I can launch Psychopy from the Start menu I should be okay.

1 Like

Yeah, there isn’t really an app; PsychoPy itself is started via Python. Besides the workaround above, I haven’t figured out how to make this work via “Open With”