psychopy.org | Reference | Downloads | Github

PsychoPy Does Not Open .psyexp Files Properly + Keeps Opening A .js File

Hi,

I just installed the latest version of PsychoPy (2021.2.3) last week and it’s been working great for me. However, today I tried to open a .psyexp file and it just opens blank with “untitled.psyexp” appearing in the window header. It appears to be loading something in the background as the watch icon is present when navigating the GUI, but it never loads.

What’s more confusing is my machine stopped defaulting to PsychoPy when double-clicking on the .psyexp file to open it; I had to manually open the file in the GUI and/or point Finder to PsychoPy by right-clicking and going to “Open-With” – it’s very strange.

I re-installed PsychoPy on my machine to no success. This phenomenon happens with all .psyexp files on my drive. Does anyone have any pointers?

Mac OS 10.14.6
2018 MacBook Pro
No updates to my OS since the last time I successfully worked with PsychoPy.

An update / another element to this:

I have found that the ordering of some of my routines in the .js file are in a different order than they appear in Builder (the flow sequence near the bottom). It looks like when I brute-force open my .psyexp files I can view my Builder contents and make changes. I was trying to sync my files to Pavlovia to pilot and was wondering why my new routine wasn’t being shown (I added it to the beginning of the experiment). Turns out it was tacked-on to the end of the file.