Newly created projects give "missing experiment block in configuration" error

I have been using Pavlovia just fine for weeks, and uploaded a new Psychopy project that was unchanged from a previous one. Upon trying to pilot the new project I get the following error:

"Unfortunately we encountered the following error:

  • when starting the experiment
  • when configuring PsychoJS for the experiment
  • missing experiment block in configuration
    Try to run the experiment again. If the error persists, contact the experiment designer."

This is the same error mentioned here:

In that thread the issue was on Pavlovia’s end, not the user’s. I’m wondering if there has been another update to Pavlovia recently which is causing the problems.

Hello @Jesse_Cresswell ,

Could you share the full path of your experiment with me? I’ll have a look for you.


Thanks Alain,

Here is the experiment where I get the error:

Here an almost identical experiment (only supporting csv and png files are changed, not the Psychopy code) which I uploaded a week ago and is still working fine.

I have flipped them to public for the sake of this forum. Thanks again,

Luckily I’m back quickly with the answer.

I had added a file ‘config.json’ to my repo with metadata unrelated to Psychopy. I did not realize that Psychopy will look for and try to use a file ‘config.json’, so obviously the one I provided had garbage data from Psychopy’s point of view. Removing the file puts everything back to normal.

I’ll mark this as solved.

1 Like