Experiments run before give 404 error

URL of experiment: https://run.pavlovia.org/lendulet_nyelvelsajatitas/nad_online_letterid/html; Sign in · GitLab

Description of the problem: We have some experiments (including this one linked above) that were collecting data without any issue for more than a year. We are now restarting data collection, but experiments cannot be opened and the browser gives a 404 not found error upon opening the link. We did not modify anything in these tasks/files, as can be seen in the example GitLab repo, the last commit was 2 years ago, and the experiment run smoothly last December.

Maybe it is related to the data migration between servers?

Thank you in advance,

I think that this may be related to copies of materials not being copied across during the migration. I would recommend that you remove html from Experiment Settings / Online and resync. I think that that hasn’t been needed since 2020.2. Is the remote html folder currently empty?

Thank you for the response, @wakecarter!

The html folder is not empty, it contains the .js files and the resources:

Do you recommend the sync with the most recent version of Psychopy? I haven’t updated it for ~2 years, and so I am a bit nervous if the sync would go smoothly with this old experiment version!

Thank you,

I understand your reluctance to update. Please could you add me (Wake) as a developer to the Gitlab and I’ll see if I can spot the issue?

Sure, thank you @wakecarter, I’ve added you to the project.

Thanks. I’ve had a look and I can’t see anything unusual with the repository. You can remove me again now. I believe the issue is that Pavlovia experiments now run from a separate server from Gitlab and because you have an html folder, the necessary files have not been copied across. I believe this is something @apitiot can fix for you without you having to edit the experiment.

Dear @kriszti ,

The issue was indeed linked to the move to the new server.
I have just fixed that for you, and your experiment is running again.
With my apologies for the glitch!
Best wishes,


Dear @apitiot,

Thank you very much for the fix!

Actually, we have three more experiments that should also be fixed:

(I didn’t link all of them before because I wondered if this had some general solution.)

Could you help bringing back these as well?

Thank you,

All dorka.dobo experiments are now back up and running as well.


1 Like

Thank you @apitiot!! :slight_smile:

However, for me, this one still doesn’t open for me: https://run.pavlovia.org/dorka.dobo/sat-mc-ii/html/ (I’ve deleted browser cache data as well.)

Could you have a look on this?

I believe it might have taken a little longer than the others. I can run it from my end.
Would you give it another try?


Now it works here, as well!
Thank you!! :slight_smile:

Hi @apitiot,

Could this above problem be caused by files being in use during data migration (we wonder this because we did not have any problem with experiments not in use during the migration period). If so, could you find a systematic solution for this? My colleagues are concerned about their experiments (in accounts with the cogsci.bme.hu domain) – should I tell them that they should check their experiments one by one whether they can be opened?

Thank you again for your help,


Hello @krizti,

I made extra sure that all experiments with recent sessions (from the past couple of years) were copied over. So there should not be any issue with those.
I have just checked the experiments of all users associated with the email domain you gave me and they all seem fine to me. I believe you are good to go.


Hi Alain,

Thank you very much for your help!! :blush: