New experiments cannot be uploaded and always point to a deleted project repo when trying to push to GitLab

URL of experiment:

Description of the problem:

I wanted to upload a new project (never uploaded before) to Palovia but I got a pop up window when “view the details of the project”

The “create new project window” never show up, PsychoPy always tries to upload to a repo “arrows” that I have already deleted in GitLab. I also tried to upload other new projects, got same error.
I also get “Cannot connect to Pavlovia server” very often (not the internet problem). I solved this problem by transferring all experiments to another computer and uploaded to Pavlovia again. It worked.
I also uninstalled and reinstalled the software on the laptop that I have problem with, I got the same errors.

The error message I got from syncing the project is

Traceback (most recent call last):
File “C:\Users\j301f208\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\app\builder\”, line 1369, in onPavloviaSync
File “C:\Users\j301f208\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\app\builder\”, line 808, in fileExport
File “C:\Users\j301f208\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\”, line 729, in showCoder
File “C:\Users\j301f208\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\app\coder\”, line 2734, in setOutputWindow
File “C:\Users\j301f208\AppData\Local\Programs\PsychoPy\lib\site-packages\wx\lib\agw\aui\”, line 6388, in Update
File “C:\Users\j301f208\AppData\Local\Programs\PsychoPy\lib\site-packages\wx\lib\agw\aui\”, line 6582, in DoUpdate
File “C:\Users\j301f208\AppData\Local\Programs\PsychoPy\lib\site-packages\wx\lib\agw\aui\”, line 8773, in Repaint
client_dc = wx.BufferedDC(wx.ClientDC(self._frame), wx.Size(w, h))
wx._core.wxAssertionError: C++ assertion “m_buffer && m_buffer->IsOk()” failed at …..\src\common\dcbufcmn.cpp(134) in wxBufferedDC::UnMask(): invalid backing store

Invalid backing store can usually be solved by closing the Coder view and trying again. I think in your case might have been caused by using the local JS test run button before syncing for the first time

Could be. But I tested by creating a new project without using the local JS test run. I got the same error message. This error seems to contaminate the following new experiments that prevent them from being uploaded.

The problem that I have is that all new projects are considered by PsychoPy as an existing (but deleted) Gitlab repo and won’t let me initiate a new repo but keep uploading to the none existing repo.

Are you creating new projects in the same folder as the old ones?

Thanks for helping me out. :grinning: The new projects are in new folders.