My experiment won't run online

Hello! My project could run successfully on the runner and my codes could converted to JS smoothly. I pushed it to the pavlovia and “49.7557 INFO Successful sync at: 23:39:50, took 3.617s
<Response [405]>”. But the project on the Pavlovia seems to be the previous version, I don’t know how to deal with the problem. I looked through the past question but there seems no good solutions.Problem with pushes - changes in gitlab.pavlovia does not appear in
Even though when I create a new project with the same code, it’s still the previous version (the last time I run online experiment on Pavlovia)
Could anyone help me with this issue? Thanks a loooooot!!!

Have you tried my usual answer to this issue?

Or is the problem that your GitLab repository isn’t showing the new files? Each file should be tagged with the name of the commit where it last changed.

YES, I tried your methods( ctrl+shirt+r OR incognito mode) But they didn’t work. And I checked the gitlab it actually showed the latest version with the information I wrote when pushing the changes.
What’s more, I tried to upload another project(others project,not related to my current one) but everything turns out fine.
I begin to think that if the logic behind the online experiment and the runner are different? But my experiment(built in builder) can run very well in the runner and in Code component, all my python codes can be transformed into JS smoothly. So, what’s wrong with the online one?
No matter what changes I made in the current codes, and I pushed it online(even I copy another same .psyexp AND created a new project based on that), it will always show the version I run the experiments of this serie for the first time in Pavlovia.

Do you have multiple psyexp files in the same folder?

NO,there are not.

:frowning: Moreover I downloaded the zip file on the gitlab and reruned it locally. Everything was great. What’s wrong with Pavlovia? I checked the JS script too, there seems to include all the latest updates…:frowning:

Please could you add me (Wake) as a developer so I can see for myself. What is the first point in the study which shows it isn’t the latest version?

Thank you! I have just invited you.

What I can see is a repository created yesterday with the psyexp and py files updated to version 0 about 5 minutes after the initial creation. The js file didn’t change at that point. Is this new repository also showing the issue? If so, then please insert something near the start (such as on the instruction screen) which appears in the JS file and when running locally but not when running from Pavolvia.

1 Like

They are both the latest version (very similar) . But they can’t be run normally.

Please could you clarify?

Sorry. I mean the v0 cant run online as it should be when performed in the runner. You can definitely download them and run it locally. They are different. I’m quite confused with that

I think the problem is related to PsychoJS because when I tried to run the study in PsychoJS in a local browser the same mistake happened…
But it’s weird… How did this happend?
Moreover, I disable the code component and made some changes in other polygon components. Nothing happend when I run the project in a local browser.

I think it is. And there must be a problem in auto convertor in Psychopy

The most serious issue with your experiment is that you aren’t using the auto translation in this code component.

If you are struggling with translation to PsychoJS you need to post the specific issue you are trying to fix.

1 Like

Thank you! Yes, I found that problem. But besides it, there’re still lots of problems related to the Py-JS convertor. I will sort them out.

Again, thank you for checking my codes!